Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231026 - gdm PostLogin Failure prevents runlevel 5 access
Summary: gdm PostLogin Failure prevents runlevel 5 access
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 17:52 UTC by Sean Lawton
Modified: 2018-04-11 11:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-03 13:32:19 UTC


Attachments (Terms of Use)
xorg*log (deleted)
2007-04-03 18:22 UTC, Sean Lawton
no flags Details
xorgconf (deleted)
2007-04-03 18:23 UTC, Sean Lawton
no flags Details
xorglog (deleted)
2007-04-03 18:23 UTC, Sean Lawton
no flags Details
xorglog (deleted)
2007-04-03 18:25 UTC, Sean Lawton
no flags Details
log file after letting X11 autodetect display and video (deleted)
2007-04-03 18:39 UTC, Sean Lawton
no flags Details

Description Sean Lawton 2007-03-05 17:52:39 UTC
Description of problem:

I recently had what I think was a nasty bug.  It came down to me changing
the resolution to get a projector to work with my FC5 laptop, using the
GUI interface under the Admin option "Display".

I can't recall exactly why/how, but at some point system-config-display
--reconfig was run (not by command line) to try to to fix the resolution
being off.  I think it was during a reboot after I changed the resolution
while I had the projector "plugged in".

It seems that this changed the /etc/X11/xorg.conf so the top section that
refers to mouse (serverlayout) did not refer to inputdevice and inputdevice
did not refer to synaptic, and synaptic did not have in the synaptics
config section option "SHMConfig".

This caused gdm to not allow logins.  I was able to go to runlevel 3,
startx and start looking for log entries to trouble-shoot.

Before realizing the problem I tried to comment out syndaemon in
/etc/gdm/PostLogin/Default.  This fixed the problem and allowed me to
figure out how to change the xorg.conf file back to its original form (by
comparison).

Anyway, reconfiguring the display (with GUI interfaces) should not change
the synaptic configuration of xorg.conf.  So I would call it a bug.  It
causes the user to subsequently be locked out of runlevel 5 and the
problem is hard to trace.

I thought I should point this out to someone.  If you are not the
appropriate person, please let me know so I can resend this e-mail to
someone who can address it.

Version-Release number of selected component (if applicable): 2.6.18-1.2257.fc5

How reproducible: I haven't tried.


Steps to Reproduce:
1.system-config-display --reconfig
2.reboot

Comment 1 Matěj Cepl 2007-04-02 14:11:54 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 2 Sean Lawton 2007-04-03 18:22:26 UTC
Created attachment 151598 [details]
xorg*log

Comment 3 Sean Lawton 2007-04-03 18:23:10 UTC
Created attachment 151599 [details]
xorgconf

Comment 4 Sean Lawton 2007-04-03 18:23:51 UTC
Created attachment 151600 [details]
xorglog

Comment 5 Sean Lawton 2007-04-03 18:25:17 UTC
Created attachment 151602 [details]
xorglog

Comment 6 Sean Lawton 2007-04-03 18:39:26 UTC
Created attachment 151607 [details]
log file after letting X11 autodetect display and video

Comment 7 Matěj Cepl 2007-07-03 13:50:24 UTC
Fedora Core 5 is no longer supported, please, could you reproduce this bug with
the updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX/INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.

Comment 8 Matěj Cepl 2007-08-03 13:32:19 UTC
No information requested was provided, so I close this bug as INSUFFICIENT_DATA.
Reporter, if you could, please, reopen with additional information.



Note You need to log in before you can comment on or make changes to this bug.