Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231020 - ecj does not recognize -Wall, -Werror, nor -W
Summary: ecj does not recognize -Wall, -Werror, nor -W
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
: 231181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 17:22 UTC by Stepan Kasal
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 20:43:16 UTC


Attachments (Terms of Use)

Description Stepan Kasal 2007-03-05 17:22:55 UTC
When I call latest
   gcj -C -Wall foo.java
then I get
   invalid warning: all
from ecj which was called by gcj.
Likewise for "-Werror" and "-W".

Could ecj handle these cases?
Or shoudl gcj strip/translate it?

Comment 1 Mark Wielaard 2007-03-05 17:38:35 UTC
Note that this was already fixed upstream:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=30585

Comment 2 Andrew Overholt 2007-03-05 18:17:34 UTC
So what needs to be done in the Eclipse SDK package?

Comment 3 Tom Tromey 2007-03-05 18:23:24 UTC
Just pull in the new GCCMain.java.
You'll need this anyway for the 3.2.2 fix.


Comment 4 Andrew Overholt 2007-03-05 18:28:19 UTC
Okay, Ben can do this when he gets back from EclipseCon.  Although I'm pretty
sure he already pulled in a new GCCMain.java for the 3.2.2 fix and built it into
dist-fc7-candidate.

If it's urgent, let me know and I can spin it (or someone else can).

Comment 5 Ben Konrath 2007-03-05 23:31:22 UTC
(In reply to comment #4)
> Okay, Ben can do this when he gets back from EclipseCon.  Although I'm pretty
> sure he already pulled in a new GCCMain.java for the 3.2.2 fix and built it into
> dist-fc7-candidate.

Yep, that's right, the latest GCCMain is in 3.2.2-3 which is in
dist-fc7-candidate. Once 3.2.2-3 has been tested with a gcc build it will be
moved over to dist-fc7. I think Jakub is going to do this.

Comment 6 Jakub Jelinek 2007-03-11 16:20:29 UTC
*** Bug 231181 has been marked as a duplicate of this bug. ***

Comment 7 Tom Tromey 2007-03-30 20:43:16 UTC
I just tried this and it is fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.