Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231016 - no files flagged as "config" in gnome-screensaver rpm
Summary: no files flagged as "config" in gnome-screensaver rpm
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-screensaver
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 16:59 UTC by Ian Collier
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-05 18:45:31 UTC


Attachments (Terms of Use)

Description Ian Collier 2007-03-05 16:59:03 UTC
Description of problem:
I would like to modify the default locking behaviour for all users.  It seems I
can only do this by modifying /etc/gconf/schemas/gnome-screensaver.schemas
(unless someone has another suggestion), but this gets overwritten whenever
gnome-screensaver is updated.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.1-4.fc6

How reproducible:
Always

Steps to Reproduce:
1. rpm -qlc gnome-screensaver
  
Actual results:
No output

Expected results:
Should list some (or all) of the files from this package that reside in /etc
since that's the system config directory.

Comment 1 Ray Strode [halfline] 2007-03-05 18:45:31 UTC
So modifying the schema is actually not the right way to do it (I realize it's
misleading that the file is in /etc, that was a design mistake that I hope to
correct at some point, but it's not gnome-screensaver specific).

Probably the nicest way to do it is to roll your own config rpm.

You can get a stub rpm by installing the rpmdevtools package and then running
rpmdev-newspec.  There is also a lot of packaging information on the fedora wiki.

I would just add some %post scriplet that does something like:
GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load
%{_datadir}/my-site-config/gnome-screensaver/gnome-screensaver.entries

where gnome-screensaver.entries contains the defaults you want.

An easy way to generate the .entries file is to setup the settings in a local
user account and then use gconftool-2 --dump on /apps/gnome-screensaver

Hope that helps, and I realize it's not super straight forward.  Another option
would be to look into using sabayon.


Note You need to log in before you can comment on or make changes to this bug.