Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231010 - Bad file descriptor errors
Summary: Bad file descriptor errors
Keywords:
Status: CLOSED DUPLICATE of bug 229006
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 15:29 UTC by Prarit Bhargava
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 19:26:46 UTC


Attachments (Terms of Use)

Description Prarit Bhargava 2007-03-05 15:29:38 UTC
Description of problem:

When the console-kit-daemon starts the console is filled with Bad file
descriptor errors.

Version-Release number of selected component (if applicable):
ConsoleKit-0.1.0-5.fc7 from rawhide-20070301

How reproducible: 100%


Steps to Reproduce: 
1. Install.
2. Boot.
3.
  
Actual results:

Starting console-kit daemon: 
** (console-kit-daemon:2026): CRITICAL **: Unable to open console: Invalid argum
ent
ioctl VT_GETSTATE: Bad file descriptor
[  OK  ]
** (console-kit-daemon:2026): WARNING **: Error waiting for native console 3 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 4 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 5 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 6 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 1 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 8 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 9 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 10 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 11 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 12 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 2 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 13 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 15 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 16 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 17 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 18 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 19 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 7 act
ivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 20 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 22 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 23 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 24 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 25 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 26 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 14 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 27 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 29 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 30 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 31 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 32 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 33 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 21 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 34 ac
tivation: Bad file descriptor


** (console-kit-daemon:2026): WARNING **: Error waiting for native console 37 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 38 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 39 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 40 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 28 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 41 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 42 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 43 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 44 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 45 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 46 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 47 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 48 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 35 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 49 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 50 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 51 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 52 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 53 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 54 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 55 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 36 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 56 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 57 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 58 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 59 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 60 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 61 ac
tivation: Bad file descriptor

** (console-kit-daemon:2026): WARNING **: Error waiting for native console 62 ac
tivation: Bad file descriptor

Expected results: Console should be found and no errors should be displayed.

Additional info:

Comment 1 jmccann 2007-03-10 00:16:27 UTC
Looks like a dup of 229006 to me.

Comment 2 David Zeuthen 2007-03-19 19:26:46 UTC

*** This bug has been marked as a duplicate of 229006 ***


Note You need to log in before you can comment on or make changes to this bug.