Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231004 - Text Installation hangs going to network step
Summary: Text Installation hangs going to network step
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
 
Reported: 2007-03-05 14:54 UTC by Prarit Bhargava
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 18:36:00 UTC


Attachments (Terms of Use)

Description Prarit Bhargava 2007-03-05 14:54:14 UTC
Description of problem:

Text installation is hanging after selecting the NFS install target.

Version-Release number of selected component (if applicable): rawhide-20070301


How reproducible: 100%


Steps to Reproduce:
1. Install in text mode or over serial.
2. Select NFS install.
3. Select NFS target (in my case I used bigpapi ...)
  
Actual results:

System hangs -- user is presented with a blank screen.  Other debug screens
indicate no error.

Expected results: System should not hang.

Comment 1 Prarit Bhargava 2007-03-05 15:04:02 UTC
Does not occur on graphics install....

Comment 2 Jeremy Katz 2007-03-05 20:56:31 UTC
Should be no difference here between text and GUI... did you change trees in
between and thus get a new kernel? 

Comment 3 Prarit Bhargava 2007-03-05 21:16:17 UTC
(In reply to comment #2)
> Should be no difference here between text and GUI... did you change trees in
> between and thus get a new kernel? 

Nope.  I used the same tree (rawhide-20070301) in both cases.  I can reproduce
this 100% of the time in the text install and the gui install seems fine.

P.

Comment 4 Jeremy Katz 2007-03-05 21:22:32 UTC
What's the last thing on tty3 when it stops ... can you use sysrq to see where
things are?

Also, trying newer tree with newer kernel isn't a bad idea

Comment 5 Prarit Bhargava 2007-03-05 21:30:10 UTC
(In reply to comment #4)
> What's the last thing on tty3 when it stops ... can you use sysrq to see where
> things are?

I'll get that info in the AM when I'm back in the office.

> 
> Also, trying newer tree with newer kernel isn't a bad idea

I was trying the latest & greatest rawhide ;) -- but I'll respin with a newer
kernel to see if that changes anything.

P.



Comment 6 Jarod Wilson 2007-03-06 19:00:58 UTC
Today's rawhide is equally explodey when doing a text install. Graphical install
went fine.

Last bits on tty3:
[...]
moving (1) to step bootloadersetup
moving (1) to step networkdevicecheck
moving (1) to step network
[...and nothing...]

Meanwhile, I'm seeing two anaconda processes spinning full-bore, one using an
increasingly larger amount of memory (now up to 24.5% of 16GB).

Not quite sure what to look for in sysrq output... There are several worker
threads as well as a kauditd thread and several jfs threads -- I presume/hope
that's not JFS, but rather generic journaling file system threads, since there's
only ext3 on this box...

Comment 7 David Cantrell 2007-03-21 18:36:00 UTC
So text mode ia64 installs in rawhide are working for me.  Doesn't hang moving
to step network.  I did rewrite all of the network configuration code in the
text mode installer, so maybe that has something to do with it.

Comment 8 Prarit Bhargava 2007-03-21 18:41:59 UTC
Okay -- I'll retry tomorrow's rawhide.

Thanks David :)

P.


Note You need to log in before you can comment on or make changes to this bug.