Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231001 - abiword crashes on startup on XAP_UnixFont::getName
Summary: abiword crashes on startup on XAP_UnixFont::getName
Keywords:
Status: CLOSED DUPLICATE of bug 227192
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marc Maurer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 14:33 UTC by ritz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-06 10:50:08 UTC


Attachments (Terms of Use)

Description ritz 2007-03-05 14:33:26 UTC
Description of problem:
abiword crashes on startup

Version-Release number of selected component (if applicable):
abiword-2.4.6-3.fc7

How reproducible:
always

Steps to Reproduce:
1. start AbiWord-2.4
 
Actual results:
crashes

Expected results:
should run

Additional info:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208346912 (LWP 22222)]
0x0824de77 in XAP_UnixFont::getName ()
(gdb) bt
#0  0x0824de77 in XAP_UnixFont::getName ()
#1  0x08273c4e in GR_UnixGraphics::getGUIFont ()
#2  0x08272184 in GR_UnixGraphics::setZoomPercentage ()
#3  0x08144a8e in AP_UnixFrame::_createViewGraphics ()
#4  0x081671e3 in AP_Frame::_showDocument ()
#5  0x0816779a in AP_Frame::loadDocument ()
#6  0x08166987 in AP_Frame::loadDocument ()
#7  0x0814812f in AP_App::openCmdLineFiles ()
#8  0x081429e3 in AP_UnixApp::main ()
#9  0x0813e9aa in main ()
(gdb) list
1       /*
2        * $XFree86: xc/lib/Xrandr/Xrandr.c,v 1.13tsi Exp $
3        *
4        * Copyright © 2000 Compaq Computer Corporation, Inc.
5        * Copyright © 2002 Hewlett Packard Company, Inc.
6        *
7        * Permission to use, copy, modify, distribute, and sell this software
and its
8        * documentation for any purpose is hereby granted without fee, provided
that
9        * the above copyright notice appear in all copies and that both that
10       * copyright notice and this permission notice appear in supporting
(gdb) c
Continuing.

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb) quit

Comment 1 Marc Maurer 2007-03-06 10:50:08 UTC

*** This bug has been marked as a duplicate of 227192 ***


Note You need to log in before you can comment on or make changes to this bug.