Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231 - the Good Old ARC/2018 problem
Summary: the Good Old ARC/2018 problem
Keywords:
Status: CLOSED DUPLICATE of bug 5883
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: alpha
OS: Linux
low
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-30 10:09 UTC by pablo
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-04-14 20:25:22 UTC


Attachments (Terms of Use)

Description pablo 1998-11-30 10:09:07 UTC
RH/Alpha installation will timestamp all directories and
rpm install dates as year 2018 since the operator
is asked about the clock format (ARC/SRM) at the *end* of
the installation process, when it's a bit too late.

The installer should ask if you're using ARC *before*
installing the packages, and in case of Upgrade process,
why not peek into /etc/sysconfig/clock?

This problem has been one of the most popular topics
in axp-list at least since the 4.0 days. I hope that
things will change now that it's also reported here :-)

It's of course easy to fix wrong dates of directories
afterwards with a simple script using find, but that
doesn't fix dates in the rpm database, thus breaking rpm
--verify etc.

Comment 1 Mike Wangsmo 1998-11-30 15:40:59 UTC
I'm not sure we can easily correct this as it would require a radical
change in the install code for Alpha.

------- Additional Comments From   10/08/99 13:13 -------
Why not ask about the date format before package install on *all*
platforms...that way it would work on Alpha too. I don't see the
point in making special case code or workarounds just for Alpha.
It's just a matter of ordering the menus differently.

Comment 2 Michael Fulbright 2000-04-14 20:25:59 UTC
*** This bug has been marked as a duplicate of 5883 ***


Note You need to log in before you can comment on or make changes to this bug.