Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230983 - When changing control in gnome-theme-manager, gtk-demo crashes
Summary: When changing control in gnome-theme-manager, gtk-demo crashes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 11:09 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-24 05:47:27 UTC


Attachments (Terms of Use)

Description sangu 2007-03-05 11:09:18 UTC
Description of problem:
(gdb) bt
#0  0x008fc402 in __kernel_vsyscall ()
#1  0x008cf8ce in __lll_mutex_lock_wait () from /lib/libpthread.so.0
#2  0x008cb71c in _L_mutex_lock_79 () from /lib/libpthread.so.0
#3  0x008cb24d in __pthread_mutex_lock (mutex=0x9180d2c)
    at pthread_mutex_lock.c:81
#4  0x00ac2756 in pthread_mutex_lock (mutex=0x9180d2c) at forward.c:182
#5  0x001f945f in _cairo_ft_unscaled_font_lock_face (unscaled=0x9180c88)
    at cairo-ft-font.c:519
#6  0x001f95c3 in *INT_cairo_ft_scaled_font_lock_face (abstract_font=0x9189598)
    at cairo-ft-font.c:2450
#7  0x0012ca0b in pango_cairo_fc_font_lock_face (font=0x90e8440)
    at pangocairo-fcfont.c:272
#8  0x00d1a611 in pango_fc_font_lock_face (font=0x90e8440)
    at pangofc-font.c:593
#9  0x00d3bed8 in basic_engine_shape (engine=0x8f88390, font=0x90e8440, 
    text=0x9215c38 "Stock Item and Icon Browser", length=27, 
    analysis=0x8f3574c, glyphs=0x9128ab0) at basic-fc.c:331
#10 0x00da8a3a in _pango_engine_shape_shape (engine=0x8f88390, font=0x90e8440, 
    text=0x9215c38 "Stock Item and Icon Browser", length=27, 
    analysis=0x8f3574c, glyphs=0x9128ab0) at pango-engine.c:71
#11 0x00db9b47 in pango_shape (text=0x9215c38 "Stock Item and Icon Browser", 
    length=27, analysis=0x8f3574c, glyphs=0x9128ab0) at shape.c:51
#12 0x00dac88a in shape_run (line=0x90f2b20, state=0xbfebe870, item=0x8f35740)
---Type <return> to continue, or q <return> to quit---
    at pango-layout.c:3020
#13 0x00daf4f5 in process_item (layout=0x91feb50, line=0x90f2b20, 
    state=0xbfebe870, force_fit=1, no_break_at_end=0) at pango-layout.c:3112
#14 0x00dafa5d in pango_layout_check_lines (layout=0x91feb50)
    at pango-layout.c:3349
#15 0x00db03e7 in pango_layout_get_extents_internal (layout=0x91feb50, 
    ink_rect=0x0, logical_rect=0xbfebe9e8, line_extents=0x0)
    at pango-layout.c:2318
#16 0x00db1416 in pango_layout_get_pixel_extents (layout=0x91feb50, 
    ink_rect=0x0, logical_rect=0xbfebe9e8) at pango-layout.c:2520
#17 0x00599731 in get_size (cell=0x8f23820, widget=0x8f1a010, cell_area=0x0, 
    layout=0x91feb50, x_offset=0x0, y_offset=0x0, width=0xbfebea7c, 
    height=0xbfebea80) at gtkcellrenderertext.c:1528
#18 0x005926a4 in IA__gtk_cell_renderer_get_size (cell=0x8f23820, 
    widget=0x8f1a010, cell_area=0x0, x_offset=0x0, y_offset=0x0, 
    width=0xbfebea7c, height=0xbfebea80) at gtkcellrenderer.c:507
#19 0x0075fbb7 in IA__gtk_tree_view_column_cell_get_size (
    tree_column=0x8f25060, cell_area=0x0, x_offset=0x0, y_offset=0x0, 
    width=0xbfebeb14, height=0xbfebeb10) at gtktreeviewcolumn.c:2579
#20 0x00744690 in validate_row (tree_view=0x8f1a010, tree=0x8ebfab8, 
    node=0x8f1c4c0, iter=0xbfebebc4, path=0x8f0fa80) at gtktreeview.c:5527
#21 0x00749b57 in validate_visible_area (tree_view=0x8f1a010)
    at gtktreeview.c:5854
---Type <return> to continue, or q <return> to quit---
#22 0x00749d51 in do_presize_handler (tree_view=0xfffffffc)
    at gtktreeview.c:6195
#23 0x00749e18 in presize_handler_callback (data=0x8f1a010)
    at gtktreeview.c:6219
#24 0x009736e1 in g_idle_dispatch (source=0x9071ad0, callback=0, 
    user_data=0x8f1a010) at gmain.c:3928
#25 0x00975442 in IA__g_main_context_dispatch (context=0x8edfed8)
    at gmain.c:2045
#26 0x0097841f in g_main_context_iterate (context=0x8edfed8, block=1, 
    dispatch=1, self=0x8ee1010) at gmain.c:2677
#27 0x009787c9 in IA__g_main_loop_run (loop=0x9063158) at gmain.c:2881
#28 0x00654604 in IA__gtk_main () at gtkmain.c:1148
#29 0x0805fd46 in main (argc=150116608, argv=0x1) at main.c:927
#30 0x009fdec0 in __libc_start_main (main=0x805f600 <main>, argc=1, 
    ubp_av=0xbfebeec4, init=0x805fe50 <__libc_csu_init>, 
    fini=0x805fe40 <__libc_csu_fini>, rtld_fini=0x1c3670 <_dl_fini>, 
    stack_end=0xbfebeebc) at libc-start.c:222
#31 0x080502c1 in _start ()

Version-Release number of selected component (if applicable):
2.10.9-4.fc7

How reproducible:
always

Steps to Reproduce:
1.  start gtk-demo and gnome-theme-manager
2. change control in gnome-theme-manager
3.
  
Actual results:


Expected results:


Additional info:
pango-1.16.0-1.fc7
gtk2-engines-2.9.4-2.fc7

Comment 1 Matthias Clasen 2007-03-24 05:47:27 UTC
Looks like a cairo locking problem that I assume is fixed meanwhile. 
Reopen if you reproduce with cairo 1.4.2


Note You need to log in before you can comment on or make changes to this bug.