Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230982 - gnome-session logout (NOT the gnome-panel one) doesn't work
Summary: gnome-session logout (NOT the gnome-panel one) doesn't work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-05 11:00 UTC by Frank Arnold
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-19 07:39:06 UTC


Attachments (Terms of Use)
strace output (deleted)
2007-04-17 16:05 UTC, Frank Arnold
no flags Details
gdb output (deleted)
2007-04-17 16:11 UTC, Frank Arnold
no flags Details
~/.gnome2/session (deleted)
2007-04-19 06:16 UTC, Frank Arnold
no flags Details

Description Frank Arnold 2007-03-05 11:00:52 UTC
Description of problem:
I have gnome-power-manager configured to display a logout dialog when pressing
the power button of my laptop. Effectively it's the same as `gnome-session-save
--kill --gui`. The dialog gets displayed, but is completely unresponsive. On my
desktop with FC5 the background fades out after running that command. That's not
the case on my laptop with up to date Rawhide.

Version-Release number of selected component (if applicable):
gnome-session-2.17.92-1

How reproducible:
Always.

Steps to Reproduce:
1. Login to GNOME
2. Open a terminal window
3. Run `gnome-session-save --kill --gui`
  
Actual results:
Logout/shutdown dialog gets drawn, but no actions can be performed. The only
option to get out of this is to kill gnome-session.

Expected results:
Possibility to do something inside the dialog, and actually log out.

Additional info:
With Compiz enabled, I get a blank window without controls.
The system is a PowerBook G4 with Radeon Mobility 9700.

In longer term it would be nice to sync the appearance of this dialog with the
gnome-panel dialog (accessible from the main menu).

Comment 1 Frank Arnold 2007-03-06 08:01:11 UTC
Turns out, this happens only if a11y is enabled. Without a11y it works.

Comment 2 Ray Strode [halfline] 2007-04-05 15:06:03 UTC
adding to FC7Target

Comment 3 Matthias Clasen 2007-04-11 14:30:15 UTC
Sees to work fine here with current rawhide. Do you still see this problem ?

Comment 4 Frank Arnold 2007-04-11 16:55:09 UTC
(In reply to comment #3)
> Sees to work fine here with current rawhide. Do you still see this problem ?

Yes, it's still not working. The only difference is that now no widget gets
drawn inside the dialog, even without Compiz. It's just a grey square.

But a11y support needs to be enabled in your personal preferences to reproduce this.

Comment 5 Matthias Clasen 2007-04-17 13:23:12 UTC
gnome-session-save --kill --gui 
works fine for me with a11y turned on, too.

Comment 6 Frank Arnold 2007-04-17 16:05:18 UTC
Created attachment 152830 [details]
strace output

Output of attached strace to gnome-session process. Attached before pressing
the power button.

Comment 7 Frank Arnold 2007-04-17 16:11:54 UTC
Created attachment 152831 [details]
gdb output

Output of gdb attached after pressing the power button.

If there are other things I can provide, please say so.

Comment 8 Ray Strode [halfline] 2007-04-18 18:05:10 UTC
can you attach your ~/.gnome2/session ?

Comment 9 Frank Arnold 2007-04-19 06:16:50 UTC
Created attachment 152980 [details]
~/.gnome2/session

(In reply to comment #8)
> can you attach your ~/.gnome2/session ?

Sure. Here it is.

Comment 10 Frank Arnold 2007-04-19 07:39:06 UTC
Just updated from 2.18.0-3 to 2.18.0-5, and what should I say... it works.

Maybe the fix of bug 229912 did the trick.


Note You need to log in before you can comment on or make changes to this bug.