Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230977 - Problems building madwifi after upgrading to the latest binutils
Summary: Problems building madwifi after upgrading to the latest binutils
Keywords:
Status: CLOSED DUPLICATE of bug 230964
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 09:17 UTC by Kjartan Maraas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-11 16:21:22 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2007-03-05 09:17:28 UTC
Description of problem:

With binutils 2.17.50.0.12 I get this:

[root@rivendell madwifi-ng]# make 
Checking requirements... ok.
Checking kernel configuration... ok.
make -C /lib/modules/2.6.20-1.2953.fc7/build
SUBDIRS=/home/kmaraas/cvs/madwifi-ng modules
make[1]: Entering directory `/usr/src/kernels/2.6.20-1.2953.fc7-i686'
  LD [M]  /home/kmaraas/cvs/madwifi-ng/ath_hal/ath_hal.o
/home/kmaraas/cvs/madwifi-ng/ath_hal/i386-elf.hal.o: file not recognized: File
format not recognized
make[3]: *** [/home/kmaraas/cvs/madwifi-ng/ath_hal/ath_hal.o] Error 1
make[2]: *** [/home/kmaraas/cvs/madwifi-ng/ath_hal] Error 2
make[1]: *** [_module_/home/kmaraas/cvs/madwifi-ng] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.20-1.2953.fc7-i686'
make: *** [modules] Error 2
[root@rivendell madwifi-ng]# rpm -q binutils
binutils-2.17.50.0.12-2

Works well if I downgrade to the release from test1. (2.17.50.0.9)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jakub Jelinek 2007-03-11 16:21:22 UTC

*** This bug has been marked as a duplicate of 230964 ***


Note You need to log in before you can comment on or make changes to this bug.