Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230973 - xendomains uses non-existant lsb functions
Summary: xendomains uses non-existant lsb functions
Keywords:
Status: CLOSED DUPLICATE of bug 217566
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-lsb
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lawrence Lim
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 08:09 UTC by Michael Best
Modified: 2014-03-26 00:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-18 01:48:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michael Best 2007-03-05 08:09:09 UTC
if test -e /lib/lsb/init-functions; then
        # LSB    
        echo sourcing /lib/lsb/init-functions
        . /lib/lsb/init-functions
        echo_rc()
        {
            if test ${_RC_RV} = 0; then
                log_success_msg "  [${_SMSG[${_RC_RV}]}] "
            else
                log_failure_msg "  [${_SMSG[${_RC_RV}]}] "
            fi
        }

This stanza succeeds and then these log_success_msg and log_failure_msg do not
work.  Probably related to bug 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218989
which was closed as a duplicate of:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217566

But bug 217566 does not exist so I can't confirm that this problem has been solved.

I also saw this bug in Fedora Core 6.

Comment 1 Lawrence Lim 2007-06-18 01:48:42 UTC
Resolving this bug as a duplicate of 217566 as part of 5.1 update. Please let me
know if problem still exist later. Thanks.

*** This bug has been marked as a duplicate of 217566 ***


Note You need to log in before you can comment on or make changes to this bug.