Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230966 - failure to open software
Summary: failure to open software
Keywords:
Status: CLOSED DUPLICATE of bug 230965
Alias: None
Product: Fedora
Classification: Fedora
Component: ac-archive
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 04:21 UTC by roger benham
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-05 04:39:08 UTC


Attachments (Terms of Use)

Description roger benham 2007-03-05 04:21:40 UTC
Description of problem:

Component: Software Manager
Summary: TB6b5e0e87 config.py:661:_getsysver:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 446, in main
    pm = PackageManager(options.config)
  File "/usr/sbin/pirut", line 60, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 124, in 
__init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 125, in 
doConfigSetup
    self.conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 598, in 
readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, 
startupconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 661, in 
_getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x8a91d2c>
distroverpkg: redhat-release

Comment 1 roger benham 2007-03-05 04:25:21 UTC
I do not seem able to open the software installer.
Further, every time that I download software, I cannot install it. How do I 
access my downloads to send you a report?
Thanks,
Roger (very much not a geek).

Comment 2 Jens Petersen 2007-03-05 04:39:08 UTC

*** This bug has been marked as a duplicate of 230965 ***


Note You need to log in before you can comment on or make changes to this bug.