Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230964 - FreeBSD elf is no longer recognized, cannot compile MadWifi
Summary: FreeBSD elf is no longer recognized, cannot compile MadWifi
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
: 230977 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 04:16 UTC by Pavel Roskin
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.17.50.0.12-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-14 10:19:25 UTC


Attachments (Terms of Use)
The problematic file, compressed with bzip2 (deleted)
2007-03-05 04:16 UTC, Pavel Roskin
no flags Details


Links
System ID Priority Status Summary Last Updated
Sourceware 3826 None None None Never

Description Pavel Roskin 2007-03-05 04:16:38 UTC
Description of problem:
Compiling MadWifi (Linux driver for Atheros chipset) involves linking against a
closed source binary called HAL (hardware absraction layer).  The binaries are
compiled for FreeBSD by a FreeBSD developer who has access to Atheros
documentation and source code.  Stating a few days ago, the build is failing
because ld doesn't understand the binary:

  LD [M]  /home/proski/src/madwifi/ath_hal/ath_hal.o
/home/proski/src/madwifi/ath_hal/i386-elf.hal.o: file not recognized: File
format not recognized

It's not just ld.  Other tools fail to understand the binary:

$ nm i386-elf.hal.o 
nm: i386-elf.hal.o: File format not recognized

Exactly the same binary is recognized on Fedora Core 6:
$ nm i386-elf.hal.o |wc -l
428

Version-Release number of selected component (if applicable):
2.17.50.0.12-2

How reproducible:
Always

Steps to Reproduce:
1. Download MadWifi sources:
svn co http://svn.madwifi.org/trunk madwifi
2. Try to compile it:
cd madwifi
make
  
Actual results:
Build fails with the message "File format not recognized"

Expected results:
Build succeeds

Additional info:
The kernels distributed with Fedora may have other issues, so please use "make
-k" or run make in the ath_hal directory to avoid irrelevant problems.

Comment 1 Pavel Roskin 2007-03-05 04:16:38 UTC
Created attachment 149240 [details]
The problematic file, compressed with bzip2

Comment 2 Pavel Roskin 2007-03-07 07:52:27 UTC
The problem can be reproduced with binutils-2.17.50.0.12 from the binutils SRPM
without Fedora patches.  However, the problem cannot be reproduced with today's
CVS version of binutils.  I think binutils needs to be updated to the CVS
version.  It's not like we are distributing official releases anyway.

Comment 3 Jakub Jelinek 2007-03-11 16:21:34 UTC
*** Bug 230977 has been marked as a duplicate of this bug. ***

Comment 5 Jakub Jelinek 2007-03-14 10:19:25 UTC
Fixed in binutils-2.17.50.0.12-3 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.