Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230958 - USB memory stick won't mount: Error org.freedesktop.Hal.PermissionDenied.
Summary: USB memory stick won't mount: Error org.freedesktop.Hal.PermissionDenied.
Keywords:
Status: CLOSED DUPLICATE of bug 228110
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 03:01 UTC by david.hagood
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-05 03:46:18 UTC


Attachments (Terms of Use)

Description david.hagood 2007-03-05 03:01:19 UTC
Description of problem:
Inserting a memory stick into a USB memory stick reader no longer causes the
memory stick to be auto-mounted - instead an error is generated.

Version-Release number of selected component (if applicable):
hal-0.5.9-0.git20070218.fc7
gnome-volume-manager-2.17.0-4.fc7


How reproducible:
Every time

Steps to Reproduce:
1. Start X+Gnome
2. Insert memory stick into USB reader.

  
Actual results:
An error dialog is displayed:
Cannot mount volume.
Error org.freedesktop.Hal.PermissionDenied.
Details
  Permission denied: Not in active session

Expected results:
Memory stick should be mounted under /media.
Nautilus should open a window showing the stick's contents.


Additional info:

Comment 1 David Zeuthen 2007-03-05 03:20:11 UTC
Are you logging in via gdm?

Comment 2 david.hagood 2007-03-05 03:26:15 UTC
No, via runlevel 3 + text login + startx.


Comment 3 David Zeuthen 2007-03-05 03:46:18 UTC
This will be fixed shortly (xinit needs to poke ConsoleKit). Until then you need
to login via gdm if you expect this to work.

*** This bug has been marked as a duplicate of 228110 ***


Note You need to log in before you can comment on or make changes to this bug.