Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230956 - USB mass-storage devices mounted with uid=root by HAL
Summary: USB mass-storage devices mounted with uid=root by HAL
Keywords:
Status: CLOSED DUPLICATE of bug 234716
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-05 02:44 UTC by Dan Fuhry
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 19:30:07 UTC


Attachments (Terms of Use)

Description Dan Fuhry 2007-03-05 02:44:25 UTC
Description of problem:
When mounting USB mass-storage hotplug devices, the drive is mounted with
uid=root. This prevents writing to the disk unless the disk is umounted and
remounted manually.

Version-Release number of selected component (if applicable):
HAL package version: 0.5.8.1

How reproducible:
Very - seen on multiple computers

Steps to Reproduce:
1. Install clean FC6
2. Update system to latest packages
3. Plug in iPod, USB flash drive, etc. and try to make a folder or something on
that drive
  
Actual results:
"Permission denied" error

Expected results:
Partition should have been mounted in a way that I would be able to write to it,
either with mode=0755 or uid=dan.

Additional info:

Comment 1 David Zeuthen 2007-03-05 03:20:37 UTC
What file system is on the device?

Comment 2 Dan Fuhry 2007-03-05 16:58:30 UTC
The file system is vfat. It mounts fine on my desktop PC, which runs openSUSE 10.2.

Comment 3 Dan Fuhry 2007-03-05 17:27:12 UTC
Corrections:

 1) First post: I meant mode=0777
 2) Second post: By "fine" I mean it mounts in a way that I can write to the
disk without remounting the partition.

Comment 4 David Zeuthen 2007-04-03 19:30:07 UTC

*** This bug has been marked as a duplicate of 234716 ***


Note You need to log in before you can comment on or make changes to this bug.