Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230941 - F7t2: IPv6 stateless autoconfig broken w/ network install
Summary: F7t2: IPv6 stateless autoconfig broken w/ network install
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
: 231502 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 22:57 UTC by Mark McClelland
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 15:13:48 UTC


Attachments (Terms of Use)

Description Mark McClelland 2007-03-04 22:57:25 UTC
Description of problem:
IPv6 stateless autoconfig ("Automatic neighbor discovery") doesn't work when
setting up TCP/IP for a network install of Fedora 7 test 2 (either i386 or
X86_64). It looks like it is trying to do DHCPv6 instead; selecting DHCPv6 gives
identical results. There is no DHCP/DHCPv6 or IPv4 connectivity on this
interface. Here's the relevant anaconda log:

14:20:35 INFO    : need to set up networking
14:20:35 INFO    : going to pick interface
14:20:41 INFO    : going to do getNetConfig
14:20:41 INFO    : eth1 is not a wireless adapter
14:20:55 INFO    : DHCP eth1  - bringing link UP - 11043 65
14:20:55 INFO    : DHCPv6: NIC: 0x93e5a0 eth1 0x93e3f0
14:21:41 INFO    : DHCPv6 eth1 - state: DHC_TIMEDOUT
14:21:41 ERROR   : DHCPv6 eth1 - TIMED OUT - failure.

(I also tried with eth0 and got the same result)

Version-Release number of selected component (if applicable):
Fedora 7 test 2

How reproducible:
Every time

Steps to Reproduce:
1. Start anaconda from CD (boot.iso)
2. Choose HTTP install source
3. Choose network interface
4. At "Configure TCP/IP" dialog, uncheck "Enable IPv4 support"
5. Leave IPv6 and "Automatic neighbor discovery" enabled, and select "OK"
  
Actual results:
Box appears that says "Sending request for IP information for eth1". The box
disappears after a minute, and the "Configure TCP/IP" dialog is still there.

Expected results:
Should automatically get network prefix from radvd server

Comment 1 Mark McClelland 2007-03-05 00:02:27 UTC
I should also mention that stateless autoconfig ultimately does seem to work,
but only if I choose "Manual configuration" and enter an arbitrary address
within my  /64. See Bug 230949 for more info.

Comment 2 David Cantrell 2007-03-08 20:01:27 UTC
Fixed in rawhide.  Thanks. (reassigned back to anaconda since that's where the
bug was)

Comment 3 David Cantrell 2007-03-09 15:57:20 UTC
*** Bug 231502 has been marked as a duplicate of this bug. ***

Comment 4 Mark McClelland 2007-03-12 02:38:39 UTC
I tried the boot.iso from this morning's build and it's still broken. When I hit
OK at the "Configure TCP/IP" dialog, I see a messagebox appear for an instant
and then I'm back at the same dialog. This is what appears in anaconda's log
when I do that:

CRITICAL: dhcp_nic: both DISABLE_DHCPv6 and DISABLE_DHCv4 (sic) set.


Comment 5 David Cantrell 2007-03-12 15:13:48 UTC
Corner case I wasn't trapping in doDhcp() in net.c in loader.  If we reach
doDhcp() and the user has caused both DHCP clients to be disabled, I return and
push you to the manual network configuration screens (if appropriate).

Fixed now in rawhide.  Thanks for the feedback.


Note You need to log in before you can comment on or make changes to this bug.