Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230940 - openoffice.org-core was not installed despite being a rpm requirement
Summary: openoffice.org-core was not installed despite being a rpm requirement
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 22:46 UTC by William Lovaton
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: test3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-21 19:07:48 UTC


Attachments (Terms of Use)
Seems a pirut specific issue (deleted)
2007-05-01 18:16 UTC, William Lovaton
no flags Details

Description William Lovaton 2007-03-04 22:46:53 UTC
Description of problem:
After installing OpenOffice with pirut, it doesn't startup because
/usr/lib/openoffice.org/program/soffice doesn't exists.  I get the following
message:
[william@localhost ~]$ export LANG=en_US.UTF-8
[william@localhost ~]$ oowriter 
/usr/bin/oowriter: line 2: /usr/lib/openoffice.org/program/soffice: No such file
or directory
/usr/bin/oowriter: line 2: exec: /usr/lib/openoffice.org/program/soffice: cannot
execute: No such file or directory

I installed the following packages:
[william@localhost ~]$ rpm -qa | grep -i openoffice
openoffice.org-draw-2.2.0-9.2
openoffice.org-xsltfilter-2.2.0-9.2
openoffice.org-calc-2.2.0-9.2
openoffice.org-graphicfilter-2.2.0-9.2
openoffice.org-writer-2.2.0-9.2
openoffice.org-impress-2.2.0-9.2
openoffice.org-math-2.2.0-9.2


How reproducible:
Always.

Steps to Reproduce:
1. Just execute oocalc, oodraw, ooimpress, oomath or oowriter


Additional info:
The system is up to date as of today.

Comment 1 William Lovaton 2007-03-04 23:54:45 UTC
Doh! it seems that pirut didn't install the openoffice.org-core package and that
seems to be the real problem.  I am installing it right now with yumex to check
if that is true (I'll confirm later).

So the real bug is: why the packages listed in the original bug report didn't
depend on openoffice.org-core package?? I checked the information section for
those packages in pirut and it says that they requires it but I don't know why
the package didn't got installed.

I just installed the Live CD and after applying the updates I proceeded to
install more software that I needed, openoffice being among them.

Another thing: why yumex says that openoffice.org-core package depends on:
- tomcat5-jsp-2.0-api.i386 0-5.5.17-6jpp.2 - u
- tomcat5-servlet-2.4-api.i386 0-5.5.17-6jpp.2 - u

among others... that sounds a bit weird to me.

Comment 2 William Lovaton 2007-03-05 02:28:58 UTC
Noe that I installed openoffice.org-core package this error doesn't happen any
more but still openoffice doesn't start.

I type oowriter in the terminal and it stays there doing nothing, no disk
activity, no CPU activity.

Looking at 'ps aux' output I get the following:
william   2456  0.0  0.2   4620  1144 pts/0    S+   21:18   0:00 /bin/sh
/usr/lib/openoffice.org/program/soffice -writer
william   2464  0.2  0.5  41116  3016 pts/0    Sl+  21:18   0:00
/usr/lib/openoffice.org/program/javaldx
william   2485  1.8  5.4  60940 27968 pts/0    Sl+  21:18   0:00 /usr/bin/gij
-classpath /usr/lib/openoffice.org/program JREProperties

Look at /usr/bin/gij ...  Why is it running a Java interpreter? OpenOffice isn't
written in Java, right?

Conclusion: I can't still get OO.o to run properly.


Comment 3 Caolan McNamara 2007-03-05 08:05:52 UTC
a)
rpm -qR openoffice.org-writer|grep core
openoffice.org-core = 1:2.2.0-9.2

as do the other packages, so the rpms are correct in that they require -core.
How on earth they got installed without -core getting installed baffles me.
There is no problem with the requirements of the packages themselves.

b)
openoffice.org-core requires bsh (beanshell) bsh requires bsf, bsf requires
tomcat-foo-api. It's not a direct requirement of OOo, but a requirement of a
requirement. This is a correct requirement from OOo, it needs bsh to be complete.

b)
the failure to start is gij bug #226959

Comment 4 William Lovaton 2007-03-05 12:49:46 UTC
Right, it seems an RPM problem, I reported another bug to sendmail:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=230960

sendmail depends on hesiod and despite being in the requirements it doesn't get
installed causing errors during sendmail start up.  So I guess this is the same
rpm bug bitting openoffice.

Cheers.

Comment 5 Jeremy Katz 2007-03-05 20:15:54 UTC
What version of yum did you have installed when installing these packages?

Comment 6 William Lovaton 2007-03-06 01:10:12 UTC
rpm-4.4.2-40.fc7
yum-3.1.3-2.fc7


Comment 7 Jeremy Katz 2007-03-07 22:04:08 UTC
Can you see if this still happens with yum 3.1.4 which will be in rawhide tomorrow?

Comment 8 William Lovaton 2007-03-08 00:18:10 UTC
/me scratch head/
How do I test this if openoffice is already installed? should I just uninstall
every openoffice package and try installing again?

As a preliminary test with software versions specified in comment #6 I tried to
remove openoffice.org-core alone.  With RPM (rpm -e openoffice.org-core) it says
that there is a bunch of packages that depends on it (Test OK).  With yum (yum
remove openoffice.org-core) it offers to remove the dependencies too (Test OK).


Comment 9 William Lovaton 2007-03-30 18:53:21 UTC
Jeremy,  I think this is fixed in Test3.  Right now I am running the Live CD and
I yum install the writer component and it pulls all the required components
including openoffice.org-core.

So, it's fine by me if you mark this bug report as fixed.

Cheers.

Comment 10 Jeremy Katz 2007-03-30 19:05:14 UTC
Great, thanks!

Comment 11 William Lovaton 2007-05-01 14:48:08 UTC
DAMN!!!  This bug isn't fixed in Fedora 7 Test 4 Live CD.

I wanted to re install the whole system from scratch with the Live CD and while
adding new apps to my shiny new system I ran into this problem again:
openoffice.org-package isn't installed despite being a requirement.

As noted in comment #3 all open office applications (calc, writer, etc) requires
explicitly the openoffice.org-core = 1:2.2.0-14.6

I haven't "fixed" it yet but I suppose installing the package manually will fix
the problem.  BTW, I used pirut to install openoffice.org among other apps.

Please! someone at red hat reproduce and fix this bug since OO.o is a very
important package.  It's very easy, just:
1) Install a clean system with a Fedora Live CD
2) update to latest rawhide
3) run pirut
4) install OO.o
5) run oowriter

See??? doesn't work.

Comment 12 William Lovaton 2007-05-01 18:16:56 UTC
Created attachment 153878 [details]
Seems a pirut specific issue

I just re-reinstalled my system (again) and try installing openoffice writer
with yum.  It resolve dependencies in the right way so it seems a pirut bug.

Comment 13 Jeremy Katz 2007-05-03 02:08:42 UTC
I just did an install of the live CD and installed ooo-writer with pirut...  

Can you look closely at the dependency screen and see what it tells you it's
going to install?

Comment 14 William Lovaton 2007-05-04 02:28:21 UTC
This is weird.  pirut _does work_ now, I just did a "yum remove
tomcat5-servlet-2.4-api" which removes the following dependencies:
bsf
bsh
hsqldb
openoffice.org-calc
openoffice.org-core
openoffice.org-draw
openoffice.org-impress
openoffice.org-math
openoffice.org-writer
tomcat5-jsp-2.0-api

I then run pirut through the Applications menu and select only
"openoffice.org-writer".  it now shows openoffice.org-core packaged as one of
the deps.  I remember clearly that the first time I reinstalled my system a
couple of days ago I installed open office from pirut and the -core package _did
not_ showed up as a dep.  I then proceeded with the installation to find the
same problem as expected: oowriter won't run because the soffice binary wasn't
installed.

Then I reinstalled my system an repeat the installation with yum, it worked
fine.  What can I do?? I don't want to reinstall this OS again... may be I'll
try later with a virtual machine.

Comment 15 William Lovaton 2007-05-05 05:12:05 UTC
Sorry Jeremy... regarding the previous comment, pirut said that it was going to
install openoffice.org-core package but now I realize that it didn't.

I am now trying to reinstall the system again from scratch and try to reproduce
this problem.  I'll comment later about this.

Comment 16 William Lovaton 2007-05-21 19:07:48 UTC
Made several tests and it seems to work fine for me now.


Note You need to log in before you can comment on or make changes to this bug.