Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230937 - console-kit-daemon tries to access proc files of a non-existing process
Summary: console-kit-daemon tries to access proc files of a non-existing process
Keywords:
Status: CLOSED DUPLICATE of bug 229006
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 21:03 UTC by Michal Jaegermann
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 19:27:10 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2007-03-04 21:03:51 UTC
Description of problem:

After switching to a text console the following shows up:

** (console-kit-daemon:13687): WARNING **: Couldn't read /proc/13686/environ:
Failed to open file '/proc/13686/environ': No such file or directory

No wonder as 13686 does not exist.  In this case the daemon process
is 13687 so I guess that 13686 would be a pid of a parent process
which did "fork-and-exit" and console-kit-daemon misremembers that
number.

I was also seeing, in similar circumstances,

(console-kit-daemon:4881): GLib-CRITICAL **: g_async_queue_push: assertion
`g_atomic_int_get (&queue->ref_count) > 0' failed

but this particular one may be gone.  Hard to be absoltely sure.

Version-Release number of selected component (if applicable):
ConsoleKit-0.1.3-0.git20070301.1.fc7

How reproducible:
often enough

Comment 1 David Zeuthen 2007-03-19 19:27:10 UTC

*** This bug has been marked as a duplicate of 229006 ***


Note You need to log in before you can comment on or make changes to this bug.