Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230932 - Live CD won't boot on HP Pavilion ZE4201 (Fedora 7 Test 4)
Summary: Live CD won't boot on HP Pavilion ZE4201 (Fedora 7 Test 4)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 20:11 UTC by Bojan Smojver
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-26 11:43:41 UTC


Attachments (Terms of Use)
Output of lspci -vv (deleted)
2007-03-04 20:15 UTC, Bojan Smojver
no flags Details
Screen shot of failure (deleted)
2007-03-04 20:18 UTC, Bojan Smojver
no flags Details
Just before failure with F7T3 (deleted)
2007-03-30 06:34 UTC, Bojan Smojver
no flags Details
Final failure on F7T3 (deleted)
2007-03-30 06:35 UTC, Bojan Smojver
no flags Details

Description Bojan Smojver 2007-03-04 20:11:29 UTC
Description of problem:
Live CD won't boot and it eventually displays "Cannot find root file system!",
which is preceded by a whole bunch of libata errors.


Version-Release number of selected component (if applicable):
The one from F7T2.

How reproducible:
Always.

Steps to Reproduce:
1. Attempt to boot Live CD on HP ZE4201

  
Actual results:
Boot fails.

Expected results:
Should work.

Additional info:
I will attach a screen shot of failure and lspci output from FC6.

Comment 1 Bojan Smojver 2007-03-04 20:15:48 UTC
Created attachment 149223 [details]
Output of lspci -vv

Comment 2 Bojan Smojver 2007-03-04 20:18:08 UTC
Created attachment 149224 [details]
Screen shot of failure

Comment 3 Bojan Smojver 2007-03-30 06:33:21 UTC
Ditto Test3.

Comment 4 Bojan Smojver 2007-03-30 06:34:53 UTC
Created attachment 151256 [details]
Just before failure with F7T3

Comment 5 Bojan Smojver 2007-03-30 06:35:44 UTC
Created attachment 151257 [details]
Final failure on F7T3

Comment 6 Matthew Miller 2007-04-10 16:02:56 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 7 Bojan Smojver 2007-04-26 22:58:43 UTC
Ditto Fedora 7 Test 4 Live CD.

Comment 8 Bojan Smojver 2007-04-27 00:29:12 UTC
BTW, is there an "official" workaround for these old systems that cannot boot
with libata?

Comment 9 Will Woods 2007-04-30 19:26:11 UTC
I guess the optical drive is attached to the ALi IDE interface? That's the only
disk interface I see:

(00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4) (prog-if fa))

Do the startup messages mention which PATA module gets loaded?

Comment 10 Bojan Smojver 2007-04-30 23:36:51 UTC
I would think so. But I'll boot this up today again and I'll pay attention to
what gets loaded.

Comment 11 Bojan Smojver 2007-05-01 01:20:58 UTC
It says pata_ali. It also says "configured for MWDMA2". Later it attempts to
drop that to MWDMA1:PIO4 but without any luck. It sort of goes through a lot of
cycles where it resets the port and tries again, before finally giving up.

Loaded modules are:

ata_generic
sd_mod
pata_ali
libata
scsi_mod
ohci_mod

Comment 12 Bojan Smojver 2007-05-07 05:19:32 UTC
I see this entry in the kernel 1.3141.fc7 build:

* Fri May 04 2007 Dave Jones <davej@redhat.com>
- Disable ATAPI DMA on ALI chipsets.

That sounds promising :-)

Now, where do I get myself a Live CD of Rawhide to try this out?

Comment 13 Bojan Smojver 2007-05-24 01:31:12 UTC
I'm having a feeling this has been fixed with Rawhide circa 21 May 2007. Here is
what I did:

- downloaded and burnt boot.iso
- booted that, pata_ali loaded
- picked HTTP install
- got stage 2 image, which started anaconda
- went to VT 2 shell and mounted the CD-ROM

So, if I was able to mount the CD-ROM, pata_ali must be working OK now, right?

Comment 14 Jeremy Katz 2007-05-24 15:28:13 UTC
I think that kernel should be in the rawhide-20070517 live images.  A new set
should be going up today if things go as planned.

But Bojan's comments make me feel pretty comfortable, so marking MODIFIED

Comment 15 Bojan Smojver 2007-05-26 11:43:41 UTC
F7 Live RC2 is good! Thanks!

Comment 16 Casual J. Programmer 2007-05-28 07:46:35 UTC
This happens on a Sony Vaio PCG-SRX51P with Fedora 7 rc2 live CD.

There seems to be no Firewire driver available in the loaded kernel. The only
way to boot from CD/DVD with this notebook is an external drive connected via
Firewire.




Note You need to log in before you can comment on or make changes to this bug.