Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230931 - htdig gives no results, possible library conflict.
Summary: htdig gives no results, possible library conflict.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: htdig
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 20:06 UTC by Steve Schwartz
Modified: 2013-04-30 23:35 UTC (History)
1 user (show)

Fixed In Version: 3.2.0b6-8.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-06 08:31:10 UTC


Attachments (Terms of Use)

Description Steve Schwartz 2007-03-04 20:06:36 UTC
Description of problem: htdig does not display search results.
/var/log/httpd/error_log shows 'Premature end of script headers: htsearch ...'
When trying htsearch as per htdig.org's faq regarding this error it gives a
segmentation fault.
Without the compat-libstdc++ rpm's, /var/log/httpd/error_log complains that it
can't find libstdc++.so.5
As per htdig.org's faq, the segmentation fault is possibly related to the
libstdc++ library.
This worked properly on FC5


Version-Release number of selected component (if applicable):
3.2.0b6-7

How reproducible:
100%

Steps to Reproduce:
1. Install htdig
2. Install compat-libstdc++-296-2.96-138 and compat-libstdc++-33-3.2.3-61
3. configure htdig on webserver
4. Run a search
  
Actual results:
Searching from web gives blank page or error 500 Internal server error;
/var/log/httpd/error_log shows Premature end of script headers: htsearch ...
When running htsearch from commandline, it results in a segmentation fault.


Expected results:
Display the search results based on the database created by rundig, which is
based on the website configured in /etc/htdig/htdig.conf

Additional info:
Premature end of script headers:
  http://www.htdig.org/FAQ.html#q5.13
Segmentation Fault:
  http://www.htdig.org/FAQ.html#q5.14

Comment 1 Adam Tkac 2007-03-05 13:52:37 UTC
Could you please try to reproduce this problem with latest htdig (from rawhide)?
If segfaults still occurs please upload core dump and specify your architecture.
I'm not able to reproduce this with latest htdig on my i386.

(
for core dump do this:
$ ulimit -c unlimited
run htsearch
you can find file named core.* in your home directory
)

Regards, Adam

Comment 2 Steve Schwartz 2007-03-06 02:35:42 UTC
I've installed htdig from rawhide: htdig-3.2.0b6-10.fc7

This appears to have corrected the problem, everything is working properly.

will this be included in fc6 updates?

Steve

Comment 3 Adam Tkac 2007-03-06 08:31:10 UTC
This could be fixed in htdig-3.2.0b6-8.fc6 (will be avaliable tomorrow). If this
problem still exists please reopen this.

Regards, Adam


Note You need to log in before you can comment on or make changes to this bug.