Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230920 - Update creates unusable xfs config
Summary: Update creates unusable xfs config
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: chkfontpath
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 18:48 UTC by Pete Zaitcev
Modified: 2008-03-26 16:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-26 16:22:43 UTC


Attachments (Terms of Use)
Broken config after update (deleted)
2007-03-04 18:48 UTC, Pete Zaitcev
no flags Details

Description Pete Zaitcev 2007-03-04 18:48:32 UTC
Description of problem:

After running "yum update", xfs configuration was ruined. Presumably
fonts-japanese added ":unscaled". Current xfs stops working if it
encounters ":unscaled".

Version-Release number of selected component (if applicable):

fonts-japanese-0.20061016-3.fc7
xorg-x11-xfs-1.0.2-3.1

How reproducible:

Unclear...

Steps to Reproduce:
0. Use a config like the attached
1. Update from a previous verion of fonts-japanese
  
Actual results:

Duplicate entries for font paths, ":unscaled" is present.

Expected results:

No ":unscaled".

Additional info:

The xfs starts and seems to work, but X aborts with ``unable to open
font "cursor"''.

Comment 1 Pete Zaitcev 2007-03-04 18:48:32 UTC
Created attachment 149213 [details]
Broken config after update

Comment 2 Akira TAGOH 2007-03-05 11:15:08 UTC
You've missed comma after line 17. BTW :unscaled is automatically added by
chkfontpath though, have you modifed your xfs config file by the hand? I'm quite
not sure why it happened anyway.

Comment 3 Akira TAGOH 2007-03-05 11:16:42 UTC
s/it/missing :unscaled for 75dpi and 100dpi as well/

Comment 4 Pete Zaitcev 2007-03-05 17:43:17 UTC
I see. The "unscaled:" was not relevant. The font "cursor" got missing
because of the missing comma.

I do not edit anything by hand as a rule. I think that some other program
modifying the configuration made the paths flush with the left side at
some point. Then, the post-installation of fonts-japanese was confused
by that.


Comment 5 Akira TAGOH 2007-03-06 01:53:14 UTC
Hmm, then there are nothing else I can do on fonts-japanese. adding the font
path into xfs config really relies on chkfontpath and have never done any
special there.
Should I reassign this to chkfontpath? or what exactly is "some other program"?

Comment 6 Pete Zaitcev 2007-03-06 02:12:47 UTC
Yes, please reassign as appropriate. I'm wholly ignorant about what program
actually edits the file.


Comment 7 Akira TAGOH 2007-03-07 02:01:50 UTC
Ok. if you can provide any info when it happened and what packages were updated,
it would be helpful. AFAIK chkfontpath is only one to update xfs's config file
as the program. so I'm reassigning this to chkfontpath so far.

Comment 8 Kristian Høgsberg 2008-03-26 16:22:43 UTC
We no longer use chkfontpath or xfs, font packages are now required to drop
symlinks in fontpath.d.  Which fonts-japanese does, so I'm closing this.  Thanks
to everybody involved ;)


Note You need to log in before you can comment on or make changes to this bug.