Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230916 - updates feature doesn't work with floppy
Summary: updates feature doesn't work with floppy
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Lehman
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-03-04 18:16 UTC by Bruno Wolff III
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 18:24:57 UTC


Attachments (Terms of Use)

Description Bruno Wolff III 2007-03-04 18:16:29 UTC
Description of problem:
I tried using the updates feature of anaconda using the instructions at:
http://fedoraproject.org/wiki/Anaconda/Updates
but it didn't work with a floppy.
I was able to mount the floppy on fc5 and see the replacement raid.py file listed.
When I was attempting to install using rawhide from a couple of days ago, I
would get prompted for the device to get updates from and select fd0. But this
would fail. It did get far enough into the boot process to have access to a
shell prompt and I couldn't get the floppy to mount there either. So this may
really be only tenuously connected to anaconda. I tried mounting with no -t
option and specifying ext2, ext3, and ext and none of these worked.

Version-Release number of selected component (if applicable):
11.2.0.28-1

How reproducible:
100%

Steps to Reproduce:
1. Follow instructions at http://fedoraproject.org/wiki/Anaconda/Updates to
create floppy.
2. Use tab to edit options and add "updates"
3. Select fd0 as device to get updates from
  
Actual results:
Selecting fd0 fails


Expected results:
Install continues using updates from fd0


Additional info:

Comment 1 Jeremy Katz 2007-03-05 20:43:48 UTC
Looks like the support for cpio balls as updates.img broke filesystem images

Comment 2 David Lehman 2007-03-06 02:35:58 UTC
I verified that ext2 updates.img worked before I committed the cpio ball patch.
If this turns out to not be a dupe of 230946 we can just reopen it.

*** This bug has been marked as a duplicate of 230946 ***

Comment 3 Bruno Wolff III 2007-03-08 19:30:04 UTC
I am still seeing the boot with this morning's boot.iso.
Also I tried using an msdos file system instead of ext2 and that didn't work for
the updates, but I was able to mount it manually from a shell prompt while the X
window was prompting for the device containing the updates. I was still not able
to mount ext2 floppies at this point in the install process.

Comment 4 Bruno Wolff III 2007-03-12 18:24:57 UTC
This works with today's boot.iso.


Note You need to log in before you can comment on or make changes to this bug.