Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230909 - Kernel 2.6.19-1.2911.6.4.fc6 results in Kernel Panic
Summary: Kernel 2.6.19-1.2911.6.4.fc6 results in Kernel Panic
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 17:32 UTC by Bob Agel
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-07 14:03:22 UTC


Attachments (Terms of Use)

Description Bob Agel 2007-03-04 17:32:23 UTC
Description of problem: This kernel results in a Kernel Panic for me.  Here's
the kernel selection from /boot/grub/grub.conf:

title Fedora Core (2.6.19-1.2911.6.4.fc6)
        root (hd0,3)
        kernel /boot/vmlinuz-2.6.19-1.2911.6.4.fc6 ro root=LABEL=/ rhgb quiet
/dev/hdb1
        initrd /boot/initrd-2.6.19-1.2911.6.4.fc6.img

In fact, FC6 is on hda5, not on hdb1, which is actually the T-2 for Fedora7. 
Removing rhgb quiet and /dev/hdb1 results in the same kernel panic.  Here's the
lines leading up to it:

mkroot: expected fs options
mount: missing mount point
setting up new root fs
setuproot: moving /dev failed no such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proce: no such file or directory
setuproot: error mounting /sys: no such file or directory
switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: no such file or directory
kernel panic - not syncing: attempted to kill init!


Version-Release number of selected component (if applicable):
kernel 2.6.19-1.2911.6.4.fc6

How reproducible:
every attempt to boot

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: kernel 2.6.19-1.2911.fc6 and prior kernels all work fine

Comment 1 Bob Agel 2007-03-04 19:03:26 UTC
(typo - FC6 is on hda4, not hda5.  Sorry for the fumble fingers)

Comment 2 Fabian M. Schindler 2007-03-05 19:26:57 UTC
Here is a screenshot of my panicing kernel:
http://www.fedoraforum.org/gallery/showimage.php?i=3021

Comment 3 Chuck Ebbert 2007-03-06 14:29:21 UTC
Try "root=/dev/hda4". You might also have to edit /etc/fstab
and change everything in there to point to the right filesystems.

In general multiple Fedora installs will cause problems because they
all think they own the label "/".

Comment 4 Bob Agel 2007-03-07 00:54:01 UTC
Well, it's fixed but the fault was mine to start out with.  I had problems with
Fedora7-T1 and mounted it in fstab to make the correction, however I did not
correct fstab once the problem was solved.  That's where the 'hdb1' was found.

Unfortunately, simply removing the fstab entry did not correct the problem and I
had to remove and then reinstall the problem kernels and kmods.  Once
reinstalled, all works perfectly.  


Note You need to log in before you can comment on or make changes to this bug.