Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230886 - input/wacom device nodes not created
Summary: input/wacom device nodes not created
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: linuxwacom
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aristeu Rozanski
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 08:58 UTC by Ulrich Drepper
Modified: 2008-01-07 16:48 UTC (History)
0 users

Fixed In Version: 0.7.4_1-2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-07 16:48:46 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2007-03-04 08:58:13 UTC
Description of problem:
When plugging in a Wacom graphire 3 board the rules in
/etc/udev/rules.d/60-wacom.rules are not applied.  The device is available as
/dev/input/event3 but the /dev/input/wacom symlink is not created.

Version-Release number of selected component (if applicable):
linuxwacom-0.7.4_1-2.1.x86_64

How reproducible:
always

Steps to Reproduce:
1.plug in graphire tablet
2.
3.
  
Actual results:
no /dev/input/wacom* symlink

Expected results:
/dev/input/wacom* symlink present

Additional info:
This is what /proc/bus/usb/devices bus says about the device:

T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#=  5 Spd=1.5 MxCh= 0
D:  Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=056a ProdID=0014 Rev= 3.14
S:  Manufacturer=WACOM
S:  Product=CTE-630-UV3.1-4
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr= 40mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=wacom
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms


This is found in /var/log/messages:

Mar  3 10:51:47 m kernel: usb 1-2: new low speed USB device using uhci_hc
d and address 5
Mar  3 10:51:47 m kernel: usb 1-2: configuration #1 chosen from 1 choice
Mar  3 10:51:48 m kernel: input: Wacom Graphire3 6x8 as /class/input/inpu
t3
Mar  3 10:51:48 m kernel: usbcore: registered new interface driver wacom
Mar  3 10:51:48 m kernel: drivers/usb/input/wacom_sys.c: v1.46:USB Wacom 
Graphire and Wacom Intuos tablet driver

Comment 1 Stefan Orbilt 2007-06-08 18:09:30 UTC
This bug is same as bug 196923.

Comment 2 Harald Hoyer 2007-06-11 09:45:48 UTC
$ rpm -qf /etc/udev/rules.d/60-wacom.rules
linuxwacom-0.7.4_1-2.1


Comment 3 Aristeu Rozanski 2007-08-20 21:52:11 UTC
Please try linuxwacom-0.7.4_1-2.2 (available in fc-6 testing updates). The problem
should be solved in this version.


Comment 4 Aristeu Rozanski 2008-01-07 16:48:46 UTC
The problem was fixed on an updated package. Please feel free to reopen this if
the problem persists.



Note You need to log in before you can comment on or make changes to this bug.