Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230882 - No aio completion event on I/O error
Summary: No aio completion event on I/O error
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jeff Moyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 07:01 UTC by Menny Hamburger
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 17:54:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
Add aio completion on I/O errors (deleted)
2007-03-04 07:01 UTC, Menny Hamburger
no flags Details | Diff

Description Menny Hamburger 2007-03-04 07:01:57 UTC
When the machine has an I/O error when trying to write/read from a device (I 
just pulled the FC cable between the machine and my RAID), the userland 
application does not receive an aio completion event.
The fix adds an io_error member to the direct I/O structure.

Comment 1 Menny Hamburger 2007-03-04 07:01:57 UTC
Created attachment 149201 [details]
Add aio completion on I/O errors

Comment 2 Jason Baron 2007-03-12 17:54:50 UTC

*** This bug has been marked as a duplicate of 202186 ***

Comment 3 Jason Baron 2007-03-12 17:55:55 UTC
 A test kernel with this patch is available from
http://people.redhat.com/~jbaron/rhel4/



Note You need to log in before you can comment on or make changes to this bug.