Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230875 - Please apply 0154-qdbuscpp2xml-moc_path.diff from qt-copy to qt4
Summary: Please apply 0154-qdbuscpp2xml-moc_path.diff from qt-copy to qt4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt4
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL: http://websvn.kde.org/trunk/qt-copy/p...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 04:00 UTC by Kevin Kofler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-05 14:14:03 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2007-03-04 04:00:26 UTC
Description of problem:
When called with a full path (bypassing the wrapper in /usr/bin which sets 
PATH), qdbuscpp2xml tries to run moc from the PATH and gets the Qt 3 one, 
resulting in an unusable D-Bus XML IDL file. This affects CMake, which calls 
the Qt tools with a full path. My KDE 4 packages currently have a workaround 
for that. However, there's a patch in qt-copy:
http://websvn.kde.org/trunk/qt-copy/patches/0154-qdbuscpp2xml-moc_path.diff?revision=616041&view=markup
which fixes qdbuscpp2xml so that, if it was called with a full path, it will 
also invoke moc with the same full path, obviating the workaround.

Version-Release number of selected component (if applicable):
qt4-4.2.2-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Try building KDE 3.80.x without playing with the PATH.
  
Actual results:
The build fails because unusable D-Bus XML files are generated by 
qdbuscpp2xml, which then produce unusable C++ files (for the adaptors) after 
qdbusxml2cpp. These fail the build.

Expected results:
qdbuscpp2xml works.

Additional info:
Workaround: Add this to the RPM specfile for any package invoking qdbuscpp2xml 
from CMake:
# Set these here because CMake bypasses the wrappers in /usr/bin.
export QT4DIR="`/usr/bin/pkg-config --variable=prefix QtCore`"
export PATH="$QT4DIR/bin:$PATH"

The other patches in qt-copy are also worth a look:
http://websvn.kde.org/trunk/qt-copy/patches/

Comment 1 Rex Dieter 2007-03-05 13:24:54 UTC
Very useful.
As a matter of fact, I had been intending on reviewing all the qt-copy patches
for potential inclusion.

Comment 2 Rex Dieter 2007-03-05 14:14:03 UTC
* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2.2-7
- fixup qconfig-multilib.h for powerpc/powerpc64 (#223663)
- include qt-copy's 0154-qdbuscpp2xml-moc_path.diff (#230875)



Note You need to log in before you can comment on or make changes to this bug.