Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230871 - tcp_wrappers and syslog-ng v2.0
Summary: tcp_wrappers and syslog-ng v2.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcp_wrappers
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Janousek
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 01:45 UTC by Jose Pedro Oliveira
Modified: 2013-01-10 04:12 UTC (History)
4 users (show)

Fixed In Version: tcp_wrappers-7.6-42.1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-09 09:43:54 UTC


Attachments (Terms of Use)

Description Jose Pedro Oliveira 2007-03-04 01:45:56 UTC
Description of problem:
syslog-ng 2.0.x is targeted to replace sysklogd in Fedora Core 7
(http://fedoraproject.org/wiki/Releases/FeatureSyslogNG) and one of the
problems that needs to be addressed is the tcp_wrappers support.

Right now the syslog-ng 2.0.2 (the version available in FE-devel) still
doesn't support tcp_wrappers (but versions 1.6.x did) but the support has
just been added upstream (syslog-ng snapshosts after 2007-02-28). 

The problem is that syslog-ng being one of the first daemons being loaded can
not depend on /usr files, namely libraries.


Version-Release number of selected component (if applicable):
(syslog-ng 2.0.3 snapshot)
ftp://perl.di.uminho.pt/pub/fedora/syslog-ng-2.0.2+20070304-0.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Build the above srpm in rawhide
  
Actual results:
$  ldd ../BUILD/syslog-ng-2.0.2+20070304/src/syslog-ng
        linux-gate.so.1 =>  (0x00ac0000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x46ae6000)
        librt.so.1 => /lib/librt.so.1 (0x466a2000)
        libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x43001000)
        libevtlog.so.0 => /lib/libevtlog.so.0 (0x4b805000)
  -->>  libwrap.so.0 => /usr/lib/libwrap.so.0 (0x45bf6000)  <<-- (PROBLEM)
        libc.so.6 => /lib/libc.so.6 (0x458d3000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x45a4e000)
        /lib/ld-linux.so.2 (0x458b6000)


Expected results:

Right now I see two possible solutions for the described problem:

1) use the tcp_wrappers static link

   Would be nice to have it in a separate package so that it would easier
   to detect the static dependency (tcp_wrappers-static). This would
   be similar to the glib2 split (there is now a glib2 static subpackage
   due to anaconda) and would also extend the split described in #193188.

2) move the tcp_wrappers dynamic library to /lib

   Again as done with glib2.


I believe the best solution would be the second one but I'm also insterested to
see if there others alternatives.

Thanks in advance,
jpo

Comment 1 Jose Pedro Oliveira 2007-03-07 01:44:52 UTC
Adding Jesse Keating and Bill Nottingham to the CC list.

(the mail
  https://www.redhat.com/archives/fedora-maintainers/2007-March/msg00140.html
appears to have failed in catching any attention.)


Note You need to log in before you can comment on or make changes to this bug.