Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230870 - Crash: AttributeError: 'NoneType' object has no attribute 'repoData'
Summary: Crash: AttributeError: 'NoneType' object has no attribute 'repoData'
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 233573 (view as bug list)
Depends On: 230851
Blocks: FC7Blocker 233573
TreeView+ depends on / blocked
 
Reported: 2007-03-04 01:12 UTC by Saikat Guha
Modified: 2014-01-21 22:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 21:29:33 UTC


Attachments (Terms of Use)

Description Saikat Guha 2007-03-04 01:12:51 UTC
Yum crashes without a nice error message.


[root@sioux ~]# find  /usr/lib/debug/ -type f   | xargs rpm -qf | sort | uniq |
sed 's/debuginfo-.*/debuginfo/' | xargs yum --noplugins
--enablerepo=development-debuginfo update
Setting up Update Process
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 263, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 150, in doCommand
    return base.updatePkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 538, in updatePkgs
    updates = self.up.getUpdatesTuples()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 501, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 410, in _getUpdates
    self.pkgSack.simplePkgList())
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 488, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 379, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 200, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 132, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 189, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
AttributeError: 'NoneType' object has no attribute 'repoData'









[root@sioux ~]# cat /etc/yum.repos.d/fedora-development.repo 
# Repositories updated : 2006-10-28
...
[development-debuginfo]
name=Fedora Core - Development - Debug
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/debug/
gpgcheck=0
enabled=0
...




[saikat@sioux ~]$ rpm -qa | grep yum
yum-downloadonly-1.1.1-1.fc7.noarch
yum-updatesd-3.1.3-2.fc7.noarch
yum-metadata-parser-1.0.3-2.fc7.x86_64
yum-utils-1.1.1-1.fc7.noarch
yum-kernel-module-1.1.1-1.fc7.noarch
yum-skip-broken-1.1.1-1.fc7.noarch
yum-versionlock-1.1.1-1.fc7.noarch
yum-3.1.3-2.fc7.noarch
yum-allowdowngrade-1.1.1-1.fc7.noarch
yum-changelog-1.1.1-1.fc7.noarch
yumex-1.9.3-1.0.fc7.noarch
yum-fedorakmod-1.1.1-1.fc7.noarch
yum-fastestmirror-1.1.1-1.fc7.noarch

Comment 1 Jeremy Katz 2007-03-05 20:11:15 UTC
Related to bug 230851, but this is the enable instead of the disable side of it.

Comment 2 Jiri Slaby 2007-04-06 07:53:08 UTC
I have this problem too.

Side note enable=1 in the repository config which I want to use is OK (instead
of using --enablerepo).

$ rpm -qa yum*
yum-3.1.6-1.fc7
yum-priorities-1.1.1-1.fc7
yum-metadata-parser-1.0.4-1.fc7

Comment 3 Tim Lauridsen 2007-04-06 13:09:11 UTC
I have just submitted a patch upstream to fix this issue, where repos add with
--enablerepo is not setup correctly.

Comment 4 Tim Lauridsen 2007-04-06 13:11:42 UTC
*** Bug 233573 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.