Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230859 - unhandled exception, which closes yumex
Summary: unhandled exception, which closes yumex
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL: http://www.simong.se/short-term-stora...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-03 20:55 UTC by Simon Gustafsson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.0.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-29 13:13:35 UTC


Attachments (Terms of Use)
crash dump (deleted)
2007-03-03 20:58 UTC, Simon Gustafsson
no flags Details

Description Simon Gustafsson 2007-03-03 20:55:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
It's possible to generate an unhandled exception, which closes yumex. See "Steps to Reproduce" for details

Version-Release number of selected component (if applicable):
yumex-1.2.2-1.0.fc6

How reproducible:
Always


Steps to Reproduce:
1. Click on "install" or "remove"
2. Enter "kernel" in filter box
3. Click search
4. Click on size button (above the rightmost column, a symbol indicating sorting order should occur)
5. Remove content in the filter box
6. Click on search

Actual Results:
"Exception Occurred" dialog appears, recommending me to file this as a bug. That dialog offered me to save a dump which I'll attach

Expected Results:
All packages from "install" or "remove" should be listed

Additional info:
The same exception occurs even if the size column was clicked several times. Bug #218165 might be related, but wasn't causing exceptions, and my exception occur even when the size column is correctly sorted (which hapens if you click size several times)

Comment 1 Simon Gustafsson 2007-03-03 20:58:30 UTC
Created attachment 149190 [details]
crash dump

Comment 2 Tim Lauridsen 2007-09-28 10:35:23 UTC
Please retest the issue in current yumex 2.0.x

Comment 3 Simon Gustafsson 2007-09-29 12:31:20 UTC
Unable to reproduce this bug, when retesting in latest yumex (yumex-2.0.1-1.fc6).

The size column of the package list in "Package View" could no longer be used
for sorting in this new version of yumex, and the bug could not be reproduced in
any obvious (or less obvious) way by me, so I would call this bug CLOSSED.

Being able to sort the package list by size has very little importance to me, so
I for one won't lack that feature, but I really like the huge speed improvement
I subjectively percieve while yumex 2.0.x populates the package list.


Note You need to log in before you can comment on or make changes to this bug.