Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230854 - only one resolution supported
Summary: only one resolution supported
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: 915resolution
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chris Weyl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-03 19:28 UTC by Doncho Gunchev
Modified: 2008-01-06 13:22 UTC (History)
0 users

Fixed In Version: Fedora 7 intel driver
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-06 13:22:59 UTC


Attachments (Terms of Use)
patch for /etc/rc.d/init.d/915resolution that allows configuring multiple resolution (deleted)
2007-03-03 19:28 UTC, Doncho Gunchev
no flags Details | Diff

Description Doncho Gunchev 2007-03-03 19:28:31 UTC
Description of problem:
In it's current implementation 919resolution's init script can set only one 
video mode (and the last update deleted my custom init script).

Version-Release number of selected component (if applicable):
915resolution-0.5.2-6.fc6

How reproducible:
look at /etc/rc.d/init.d/915resolution

Expected results:
should be able to set multiple resolutions (ex: 8 15/16 24 32 bit color ones)

Additional info:
I will attach a patch for /etc/rc.d/init.d/915resolution and a new example 
configuration file for /etc/sysconfig/915resolution that allows arbitry number 
of resolutions to set.

Comment 1 Doncho Gunchev 2007-03-03 19:28:31 UTC
Created attachment 149188 [details]
patch for /etc/rc.d/init.d/915resolution that allows configuring multiple resolution

Comment 2 Doncho Gunchev 2007-03-03 19:31:56 UTC
Here's the example /etc/sysconfig/915resolution config file (should I attach 
it as a file?). The second example is from my laptop (Acer Aspire 5610).
--- cut ---
# Modes to overwrite, format: RESOLUTIONS=("mode X Y [bits/pixel] [htotal] 
[vtotal]" ...)
# examples:
# RESOLUTIONS=("58 1680 1050")
# RESOLUTIONS=(
#     "38 1280 800  8" \
#     "49 1280 800 16" \
#     "58 1280 800 32" \
# )
--- cut ---


Comment 3 Doncho Gunchev 2007-09-27 17:03:54 UTC
I no longer care about this because the X11's new intel driver works fine for 
me (fc7 & fc8t1). Feel free to close if no one else needs this (someone?).


Note You need to log in before you can comment on or make changes to this bug.