Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230837 - Devhelp spits - memory corruption due to late invocation of g_thread_init()...
Summary: Devhelp spits - memory corruption due to late invocation of g_thread_init()...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: devhelp
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-03 12:57 UTC by Mayank Jain
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: devhelp-0.13-7.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-23 19:11:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 414221 None None None Never

Description Mayank Jain 2007-03-03 12:57:46 UTC
Description of problem:
Devhelp spits a MEMORY-WARNING when invoked from gedit plugin

***MEMORY-WARNING***: devhelp[12881]: GSlice: g_thread_init() must be called
before all other GLib functions; memory corruption due to late invocation of
g_thread_init() has been detected; this program is likely to crash, leak or
unexpectedly abort soon...

Version-Release number of selected component (if applicable):
devhelp-0.13-3.fc7
gedit-2.17.4-1.fc7

How reproducible:
Everytime F7 is pressed from Gedit after enabling the devhelp plugin

Steps to reproduce
1) Run gedit (gedit-2.17.4-1.fc7) from command line
2) Enable Devhelp plugin from the preferences
3) Write any small C program
4) Highlight "main" & press F7 to invoke devhelp
5) Check the MEMORY-WARNING on the gnome-terminal
  
Actual results:
MEMORY-WARNING

Expected results:
No warning

Additional info:

Comment 1 Christopher Aillon 2007-04-17 19:40:39 UTC
Should probably tackle this for F7...

Comment 2 Matthew Barnes 2007-04-23 19:11:40 UTC
Backported upstream fix to devhelp-0.13-7.fc7.


Note You need to log in before you can comment on or make changes to this bug.