Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230834 - suspend fails on notebook (IBM)
Summary: suspend fails on notebook (IBM)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-03 11:51 UTC by Ronny Fischer
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.6.20-1.2967
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-24 10:25:34 UTC


Attachments (Terms of Use)

Description Ronny Fischer 2007-03-03 11:51:44 UTC
Description of problem:
it is not possible to suspend/hibernate the computer. Same configuration on FC6
works.

Version-Release number of selected component (if applicable):
Fedora Core 7 Test 2 Kernel 2.6.20-1.2949

How reproducible:
always

Steps to Reproduce:
1. try to suspend a Thinkpad R52 with standard installation
2.
3.
  
Actual results:
neither suspend nor hibernate is working

Expected results:
suspend (acpi_s3) or hibernate

Additional info:
Hardware is a Thinkpad R52 with Pentium Mobile and 1GB RAM. ACPI and all needed
components are installed and working. The identical configuration under FC6
works (on the same machine).

dmesg includes a few messages about the event:

Mar  3 11:48:31 Oblivion gnome-power-manager: (kaonashi) Der Rechner wird in
Bereitschaft versetzt weil die D-BUS-Methode Suspend() wurde aufgerufen (in
english this would be like "the computer will be suspended because the D-BUS
called the method Suspend()")
Mar  3 11:48:31 Oblivion gnome-power-manager: (kaonashi) Permission denied: Not
in active session code='30' quark='g-exec-error-quark'
Mar  3 11:48:31 Oblivion gnome-power-manager: (kaonashi) Der Rechner wird
aufgeweckt (english: the computer will wake up)
Mar  3 11:48:31 Oblivion gnome-power-manager: (kaonashi) suspend failed

Comment 1 Ronny Fischer 2007-03-08 07:30:46 UTC
After updating the Kernel to 2.6.20-1.2967 suspend is working now.

Comment 2 Ronny Fischer 2007-03-18 10:31:37 UTC
Had to reopen the bug because with kernel 2.6.20-1.299x the uspend fails again. 
The error messages are still the same.

Bad luck.

Comment 3 Hezekiah M. Carty 2007-04-03 21:24:58 UTC
I have the same issue on a Sony Vaio VGN-S260.  Suspend works under FC6, but it
does not under 6.91 or 6.92 + updates.

I do not, however, have similarly helpful dmesg output available.

Comment 4 Hezekiah M. Carty 2007-04-04 17:32:40 UTC
I'm not sure if my issue is the same - with today's updated (April 4) my system
will suspend, but then seems to panic on resume.

I have created a separate bug -
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=235240
since I am not sure my problem belongs with this one.

Comment 5 Ronny Fischer 2007-04-07 09:56:39 UTC
With the actual kernel 2.6.20-1.3045 suspend is working again, but I want to 
leave this bug report open as I don't know if the next update of the kernel is 
working too.


Comment 6 Matthew Miller 2007-04-10 15:57:25 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 7 Valent Turkovic 2007-05-16 11:35:10 UTC
Ron: How did you make IBM R52 to resume on Fedora Core 6?
I get it to suspend but on resume everything works except that my laptop LCD
stays off and I can't use it. I know that everyhing works because if I have
external monitor connected then my external monitors turns on when I do resume
but internal stays off.

Comment 8 Ronny Fischer 2007-05-16 12:52:31 UTC
Valent: I followed this How-To to make suspend work correctly

http://www.thinkwiki.org/wiki/Problem_with_display_remaining_black_after_resume#
Solution_for_ThinkPads_with_ATI_graphic_chips_and_Intel_915.2F945GM

Comment 9 Valent Turkovic 2007-05-17 12:55:23 UTC
I Love you! I had laptop over a year and now it finally works perfectly on
Fedora Core 6! Thank you!!!

Comment 10 Valent Turkovic 2007-05-18 08:34:43 UTC
Will this fix be incorporated in F7 so that other unexperieced users don't have
to do all this and so that it "Just Works" ?

Comment 11 Richard Hughes 2007-05-24 10:25:34 UTC
See http://people.freedesktop.org/~hughsient/quirk/ for how to do this
automatically.

Comment 12 Valent Turkovic 2007-05-24 10:55:12 UTC
I have only Fedora 6 installed on my IBM laptop, but if I use Fedora 7 live cd
and test quirk and confirm it works - then I can ask you (fedora devels) to add
my this laptop to quirk list. Am I correct?


Note You need to log in before you can comment on or make changes to this bug.