Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230832 - Clock doesn't update immediately when timezone changed
Summary: Clock doesn't update immediately when timezone changed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-03 10:24 UTC by Aled Hughes
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 16:55:02 UTC


Attachments (Terms of Use)
I'm going to build this into rawhide (deleted)
2007-04-03 16:48 UTC, Ray Strode [halfline]
no flags Details | Diff

Description Aled Hughes 2007-03-03 10:24:22 UTC
Description of problem:
I'm using FC7test2 liveCD. If I alter  the timezone using the clock app located
at the top right of the desktop, the time shown in the bar doesn't update
correctly for up to a minute. This could make the user think they've not
correctly set the timezone when in fact they have.

How reproducible:
Always

Steps to Reproduce:
1. Right-click clock applet and choose "adjust date & time)
2. Go to the time zone tab and select a new timezone
3. Press OK.
4. Observe clock is still shown old time but when the next minute ticks over it
corrects itself.

Whilst it is wrong, you can right-click it and choose "Copy" - the text copied
will be the correct time. 
Also, if you bring up the "adjust" dialog again, the time shown in that dialog
is also correct.

Actual results:
The time shown should update immediately.

Expected results:
After TZ change, clock should show correct time immediately.

Additional info:
OK, so in less than 60 seconds the problem goes away, but still this behaviour
looks bad in my opinion as a novice fedora user. My first impression was that
the whole timezone change feature was broken.

Comment 1 Ray Strode [halfline] 2007-04-03 15:53:12 UTC
Does it take affect immediately if you choose the "show seconds" option?

Comment 2 Ray Strode [halfline] 2007-04-03 16:07:45 UTC
okay so it looks like the problem is we just fire up the config tool and forget
about it:

       if (gdk_spawn_on_screen (screen,
                                 NULL,
                                 argv,
                                 NULL,
                                 G_SPAWN_SEARCH_PATH,
                                 NULL,
                                 NULL,
                                 NULL,
                                 &err)) {


We should probably force a refresh when the tool exits.

Comment 3 Ray Strode [halfline] 2007-04-03 16:48:50 UTC
Created attachment 151586 [details]
I'm going to build this into rawhide

The above patch just asks the clock to refresh itself when the config tool
exits

Comment 4 Ray Strode [halfline] 2007-04-03 16:55:02 UTC
Should be fixed in tomorrow's rawhide.  Please reopen, if not.

Comment 5 Ray Strode [halfline] 2007-04-03 17:15:27 UTC
Also, you may hit bug 235064 which I ran into during testing.


Note You need to log in before you can comment on or make changes to this bug.