Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230827 - TB3a4f1e9a __init__.py:237:reposSetup:TypeError: doRepoSetup() takes exactly 1 argument (2 given)
Summary: TB3a4f1e9a __init__.py:237:reposSetup:TypeError: doRepoSetup() takes exactly ...
Keywords:
Status: CLOSED DUPLICATE of bug 230777
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-03 08:16 UTC by Peter Gordon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-03 13:58:50 UTC


Attachments (Terms of Use)

Description Peter Gordon 2007-03-03 08:16:30 UTC
The Pirut in rawhide, updated as of 20070302, fails to start. The traceback it
gives is as follows:

Component: Software Manager
Summary: TB3a4f1e9a __init__.py:237:reposSetup:TypeError: doRepoSetup() takes
exactly 1 argument (2 given)

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 462, in <module>
    main()
  File "/usr/sbin/pirut", line 458, in main
    pm.run()
  File "/usr/sbin/pirut", line 360, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 380, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 237, in reposSetup
    self.doRepoSetup(thisrepo)
TypeError: doRepoSetup() takes exactly 1 argument (2 given)

Local variables in innermost frame:
thisrepo: None
callback: <pirut.Progress.PirutProgressCallback instance at 0xfd8a70>
self: <__main__.PackageManager object at 0xf47c10>

This is with version 1.3.2-1.fc7; and changing line 237 of the __init__.py file from
    self.doRepoSetup(thisrepo)
to
    self.doRepoSetup()
appears to fix it and Pirut then works as expected.

Comment 1 Jeremy Katz 2007-03-03 13:58:50 UTC

*** This bug has been marked as a duplicate of 230777 ***


Note You need to log in before you can comment on or make changes to this bug.