Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230814 - Update to 0.11.7 - spec/src.rpm provided
Summary: Update to 0.11.7 - spec/src.rpm provided
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: banshee
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 227150 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-03 02:12 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 20:07:06 UTC


Attachments (Terms of Use)
banshee 0.12.0 spec (deleted)
2007-03-23 16:06 UTC, David Nielsen
no flags Details

Description David Nielsen 2007-03-03 02:12:22 UTC
Description of problem:

I took the liberty of updating Banshee to 0.11.7, I also fixed the spec for the
renamed schema files. It compiles and runs fine on my x86_64 machine for what
it's worth.

http://www.lovesunix.net/banshee.spec
http://www.lovesunix.net/banshee-0.11.7-1.src.rpm

Comment 1 David Nielsen 2007-03-23 16:06:57 UTC
Created attachment 150770 [details]
banshee 0.12.0 spec

Updated the spec to 0.12.0 and fixed a few minor issues. Chris if you want help
maintaining Banshee I'd gladly go through the Extras contributor process and
help keep this updated as I use it daily.

Comment 2 Christopher Aillon 2007-03-23 18:14:45 UTC
Please don't attach spec files.  Just use cvs.  You can check things out even if
you aren't a maintainer and produce diffs using 'cvs diff'.  Had you done that,
you may have noticed that the spec has been at 0.12.0 for a while.  It just is
failing to build on ppc which is why you don't see it in the repo.  If you'd
like to help solve that issue, I'd appreciate it.

Comment 3 David Nielsen 2007-03-23 18:25:56 UTC
I'm currently not an Extras contributor so I can't commit to CVS, I'm merely a
user of Banshee and I needed to get on the latest release since the rpms weren't
updated I assumed you were to busy.

I don't really have a means of testing on PPC, it sounds like something upstream
needs to fix. 

Comment 4 David Nielsen 2007-03-23 18:29:44 UTC
oh and you can remove the dbus BuildRequires, banshee needs the managed D-Bus
implementation which is not what we have in Fedora currently, you don't set the
configure switch to build against external dbus so it will build against the
bundled copy anyways.

Comment 5 Christopher Aillon 2007-03-23 18:35:46 UTC
You don't have to be a contributor, actually.  There is read-only access to cvs.
 http://cvs.fedora.redhat.com/extras.shtml 

Creating diffs against cvs is a thousand times more useful than dumping outright
specfiles on both our parts -- you know whether I've made a change but it's not
built for some reason.  And I can tell what version you made changes against,
what the specific changes were, and if there's a large different that's
unintended, can make adjustments if needed.

Comment 6 Christopher Aillon 2007-03-30 20:07:06 UTC
New mono-core was released this am and banshee finally builds against it.

Comment 7 Christopher Aillon 2007-03-30 20:07:55 UTC
*** Bug 227150 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.