Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230800 - does not run (dbus-python disagreements)
Summary: does not run (dbus-python disagreements)
Keywords:
Status: CLOSED DUPLICATE of bug 241981
Alias: None
Product: Fedora
Classification: Fedora
Component: Democracy
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thorsten Scherf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 22:51 UTC by Bill Nottingham
Modified: 2014-03-17 03:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-01 06:45:13 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2007-03-02 22:51:19 UTC
Description of problem:


[notting@nostromo: ~]$ democracyplayer 
/usr/lib/python2.5/site-packages/democracy/eventloop.py:17: RuntimeWarning:
Python C API version mismatch for module fasttypes: This Python has API version
1013, module fasttypes has version 1012.
  import database
/usr/bin/democracyplayer:81: DeprecationWarning: The dbus_bindings module is
deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  import dbus_bindings
/usr/lib/python2.5/site-packages/dbus_bindings.py:5: DeprecationWarning: The
dbus_bindings module is deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 105, in
__init__
    bus_name = BusNameFlags('org.participatoryculture.dtv.onetime', bus=bus,
flags=dbus.dbus_bindings.NAME_FLAG_DO_NOT_QUEUE)
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 53, in __new__
    retval = dbus.dbus_bindings.bus_request_name(bus.get_connection(), name,
flags=flags)
TypeError: request_name() takes no keyword arguments

Version-Release number of selected component (if applicable):

Democracy-0.9.5.1-4.fc7

Comment 1 Thorsten Scherf 2007-03-03 11:15:02 UTC
does this happen on x86 or x86_64?

Comment 2 Bill Nottingham 2007-03-03 14:58:11 UTC
This was x86.

Comment 3 Jens Petersen 2007-05-11 02:37:59 UTC
With Democracy-0.9.5.1-8.fc7.x86_64 I see the same backtrace
(without the initial warning from eventloop.py).

Comment 4 Valent Turkovic 2007-05-30 17:53:08 UTC
I just installed Democracy Player and got same error:

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 Democracy               i386       0.9.5.1-8.fc7    development       5.0 M
Installing for dependencies:
 boost                   i386       1.33.1-13.fc7    development       854 k
 gnome-python2-gtkmozembed  i386       2.14.3-2.fc7     development        27 k
 libXvMC                 i386       1.0.4-1.fc7      development        22 k
 libicu                  i386       3.6-18.fc7       development       5.2 M
 libmodplug              i386       1:0.8.4-1.fc7    development       170 k
 libmpcdec               i386       1.2.2-4.fc6      development        30 k
 wavpack                 i386       4.41-1.fc7       development       120 k
 xine-lib                i386       1.1.6-2.fc7      development       2.5 M



[rawhide@rawhide ~]$ democracyplayer 
/usr/bin/democracyplayer:81: DeprecationWarning: The dbus_bindings module is
deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  import dbus_bindings
/usr/lib/python2.5/site-packages/dbus_bindings.py:5: DeprecationWarning: The
dbus_bindings module is deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 105, in
__init__
    bus_name = BusNameFlags('org.participatoryculture.dtv.onetime', bus=bus,
flags=dbus.dbus_bindings.NAME_FLAG_DO_NOT_QUEUE)
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 53, in __new__
    retval = dbus.dbus_bindings.bus_request_name(bus.get_connection(), name,
flags=flags)
TypeError: request_name() takes no keyword arguments


Comment 5 Valent Turkovic 2007-05-30 17:54:57 UTC
I don't mean to be harsh - but do you test packages after you package them? Do
they work on your systems?

Comment 6 Thorsten Scherf 2007-06-01 06:45:13 UTC

*** This bug has been marked as a duplicate of 241981 ***


Note You need to log in before you can comment on or make changes to this bug.