Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230777 - TB3a4f1e9a __init__.py:237:reposSetup:TypeError: doRepoSetup() takes exactly 1 argument (2 given)
Summary: TB3a4f1e9a __init__.py:237:reposSetup:TypeError: doRepoSetup() takes exactly ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 230827 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 20:11 UTC by Julius B.
Modified: 2014-01-21 22:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-02 20:46:11 UTC


Attachments (Terms of Use)

Description Julius B. 2007-03-02 20:11:22 UTC
Description of problem:

nor yum neither software manager are doing _anything_.

Version-Release number of selected component (if applicable):

shipping with test 2 (upgraded from test 1)

How reproducible:

everytime

Steps to Reproduce:
1. start yum or software manager
  
Actual results:

Component: Software Manager
Summary: TB3a4f1e9a __init__.py:237:reposSetup:TypeError: doRepoSetup() takes
exactly 1 argument (2 given)

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 462, in <module>
    main()
  File "/usr/sbin/pirut", line 458, in main
    pm.run()
  File "/usr/sbin/pirut", line 360, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 380, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 237, in reposSetup
    self.doRepoSetup(thisrepo)
TypeError: doRepoSetup() takes exactly 1 argument (2 given)

Local variables in innermost frame:
thisrepo: None
callback: <pirut.Progress.PirutProgressCallback instance at 0xa0ea84c>
self: <__main__.PackageManager object at 0xa053b0c>


Expected results:

window opening to install updates and/or software

Additional info:

Comment 1 Julius B. 2007-03-02 20:16:21 UTC
sorry, it is not yum but it's pirut. yum IS working

Comment 2 Jeremy Katz 2007-03-02 20:46:11 UTC
Actually, it's an API change in yum that shouldn't have happened.  Fixed in
upstream yum. I'll likely be pulling back a patch for this later today

Comment 3 Jeremy Katz 2007-03-03 13:58:53 UTC
*** Bug 230827 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.