Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230771 - yum - Error: Package tuple ... could not be found in packagesack
Summary: yum - Error: Package tuple ... could not be found in packagesack
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 19:31 UTC by Michal Jaegermann
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-02 20:39:58 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2007-03-02 19:31:40 UTC
Description of problem:

After an update to yum-3.1.3-1.fc7 an attempt to run yum as
follows:

   yum --exclude='openoff*' update

ends up with:
....
Excluding Packages in global exclude list
Finished
Error: Package tuple (u'openoffice.org-core', u'x86_64', u'1', u'2.2.0', u'9.1')
could not be found in packagesack

An attempt to clean metadata and to start again does not help.
Backing off an update to yum-3.1.2-1.fc7 resolves the issue immediately.

Version-Release number of selected component (if applicable):
yum-3.1.3-1.fc7

How reproducible:
It looks like always.

Comment 1 Jeremy Katz 2007-03-02 20:39:58 UTC
Fixed in upstream CVS.  Will probably build a package with a roll-up of fixes
from upstream later this afternoon.


Note You need to log in before you can comment on or make changes to this bug.