Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230758 - esd blocks and hangs gnome login
Summary: esd blocks and hangs gnome login
Keywords:
Status: CLOSED DUPLICATE of bug 238680
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 18:02 UTC by ritz
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-16 21:04:58 UTC


Attachments (Terms of Use)

Description ritz 2007-03-02 18:02:51 UTC
Description of problem:
gnome login is blocked waiting on esd

Version-Release number of selected component (if applicable):
esound-0.2.36-5.fc7
gnome-session-2.17.91-2.fc7

How reproducible:
always

Steps to Reproduce:
1. start system
2. login
  
Actual results:
login hangs

Expected results:
login to work

Additional info:
killall esd is a temporary workaround
cleaned /tmp of .esd file, rebooted, no go.
strace shows is able to connect to esd, and is waiting on read on esd.

Comment 1 ritz 2007-03-05 14:27:33 UTC
workaround : disable esound from sound menu in gnome.

Comment 2 Jost Diederichs 2007-03-23 19:08:36 UTC
similar problem here:
first gnome session works fine but after logout esd doesn't get killed;
upon second login gnome hangs waiting on esd.

esound-0.2.37-1.fc7.x86_64
gnome-session-2.18.0-1.fc7.x86_64

Comment 3 Bastien Nocera 2007-04-12 14:33:04 UTC
gnome-session is supposed to kill esd on logout.

void
gsm_sound_logout (void)
{   
#ifdef HAVE_ESD 
  if (sound_events_enabled ())
    play_trigger ("logout");

  if (esd_pid)
    {
      if (kill (esd_pid, SIGTERM) == -1)
        g_printerr ("Failed to kill esd (pid %d)\n", esd_pid);
      else
        esd_pid = 0;
    }
#endif
}


Comment 4 Ray Strode [halfline] 2007-04-12 14:46:58 UTC
gnome-session will only kill esd if it started esd, yea?  but esd might get
started by its own libraries right?

Comment 5 Bastien Nocera 2007-04-12 15:29:51 UTC
(In reply to comment #4)
> gnome-session will only kill esd if it started esd, yea?  but esd might get
> started by its own libraries right?

Yes, but I believe it's the case here, as esd isn't started with -terminate.
Ritesh, could you double-check whether you have any error messages in your
~/.xsession-errors? Is esd started with any flags on your system (check with ps
aux)?

Comment 6 ritz 2007-04-13 07:20:44 UTC
to reproduce, enable system->prefences->hardware->sound->sound preferences->tick
enable software sound mixing .

log-out and login. login freezes .

nothing unusal in .xsession-errors


pstree output

  |-gdm-binary---gdm-binary-+-Xorg
     |                         `-gnome-session-+-bluetooth-apple
     |                                         |-esd

ps output
rkhadgar  7450  0.0  0.2   3880  2076 ?        SL   12:27   0:00 /usr/bin/esd -n
obeeps


typical strace output
12:27:47 connect(17, {sa_family=AF_FILE, path="/tmp/.esd/socket"}, 18) = 0
12:27:47 rt_sigaction(SIGPIPE, {0x22e7c0, [PIPE], SA_RESTART}, {SIG_IGN}, 8) = 0
12:27:47 open("/home/rkhadgar/.esd_auth", O_RDONLY) = 18
12:27:47 read(18, "3\345\245\353\3>\262\304,c\367lMa@d", 16) = 16
12:27:47 write(17, "3\345\245\353\3>\262\304,c\367lMa@d", 16) = 16
12:27:47 write(17, "NDNE", 4)           = 4

<-- kill esd at this point -->
12:27:47 read(17, 0xbfb74a70, 4) = -1 ECONNRESET (Connection reset by peer)
12:30:37 close(18) = 0
12:30:37 rt_sigaction(SIGPIPE, {SIG_IGN}, {0x22e7c0, [PIPE], SA_RESTART}, 8) = 0
12:30:37 close(17)

Comment 7 Thomas Steudten 2007-06-16 17:35:18 UTC
I can confirm this with the fresh FC7..
kill esd continues the gnome-session startup.

Comment 8 Bastien Nocera 2007-06-16 21:04:58 UTC
There's a new esound in updates-testing already.

*** This bug has been marked as a duplicate of 238680 ***


Note You need to log in before you can comment on or make changes to this bug.