Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230739 - Unable to register systems with users who are PAM enabled
Summary: Unable to register systems with users who are PAM enabled
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 500
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 16:27 UTC by Clifford Perry
Modified: 2007-07-31 18:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 22:41:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Clifford Perry 2007-03-02 16:27:57 UTC
Description of problem:
Public bug for tracking issue reported in posting to rhn-satellite-beta-users
list -
https://www.redhat.com/archives/rhn-satellite-beta-users/2007-March/msg00000.html

For the RHN 5.0 Satellite - lets please make sure that indeed PAM enabled users
are able to register systems for both Enterprise Linux 4 and 5. 

Notes from email:
-------- Original Message --------
Subject: [rhn-satellite-beta-users] PAM_auth issues.
Date: Thu, 1 Mar 2007 13:56:31 -0500
From: Jeremy Hallum <jhallum@umich.edu>
To: rhn-satellite-beta-users@redhat.com

We are testing the satellite server out, and we would like to use  
pam_auth to authenticate people using our kerberos server.

We find that we can log in fine, but when we attempt to run the  
rhn_register command from an RHEL 4 or an RHEL 5 machine, we get the  
following error:

[Tue Feb 13 10:37:26 2007] rhn_register
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 1712, in  
callAndFilterExceptions
    return function()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 477, in  
_loginPageApply
    self.loginPw.get_text())
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 211, in  
reserveUser
    return s.registration.reserve_user(username, password)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 62, in  
__call__
    message = pieces[2].strip(" '")
exceptions.IndexError: list index out of range


Anyone seen this problem?

-jeremy


--
Jeremy Hallum, Department System Administrator
Department of Astronomy,
University of Michigan
 jhallum@umich.edu



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike McCune 2007-04-11 22:41:18 UTC

*** This bug has been marked as a duplicate of 216865 ***


Note You need to log in before you can comment on or make changes to this bug.