Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230709 - API break; doSackSetup now complains if an argument is passed
Summary: API break; doSackSetup now complains if an argument is passed
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 230863 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 13:40 UTC by Jesse Keating
Modified: 2014-01-21 22:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-02 14:11:44 UTC


Attachments (Terms of Use)

Description Jesse Keating 2007-03-02 13:40:13 UTC
Previous versions of yum I was able to do:

doSackSetup(['list', 'of', 'arches'])

However now when I try this I get:

TypeError: doSackSetup() takes exactly 1 argument (2 given)

This is because the signature of doSackSetup has changed to use self, **kwargs

Changing my api call to doSackSetup(archlist=['list', 'of', 'arches']) seems to
be a work around.

Comment 1 Seth Vidal 2007-03-02 14:11:44 UTC
fixed in cvs. Thanks for the catch.

Comment 2 Jeremy Katz 2007-03-05 20:12:06 UTC
*** Bug 230863 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.