Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230691 - X hangs when trying to come out of gl screensaver
Summary: X hangs when trying to come out of gl screensaver
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 08:13 UTC by Mike Cohler
Modified: 2018-04-11 19:31 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-Xorg-1.1.1-47.6.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-04 12:57:17 UTC


Attachments (Terms of Use)
xorg.conf in current system (deleted)
2007-03-02 08:13 UTC, Mike Cohler
no flags Details
Xorg.0.log (deleted)
2007-03-02 08:14 UTC, Mike Cohler
no flags Details
new xorg.conf created with system-config-display (deleted)
2007-03-02 08:43 UTC, Mike Cohler
no flags Details
Xorg.0.log after restarting X (deleted)
2007-03-02 08:48 UTC, Mike Cohler
no flags Details
Re-doing the attachment as a text file ! Xorg.0.log after the changes (deleted)
2007-03-02 10:41 UTC, Mike Cohler
no flags Details

Description Mike Cohler 2007-03-02 08:13:13 UTC
Description of problem:When moving the mouse to come out of a gl screensaver X
hangs.


Version-Release number of selected component (if
applicable):xorg-x11-server-Xorg-1.1.1-47.6.fc6


How reproducible:Sporadic


Steps to Reproduce:
1.Let desktop running KDE go into a gl screensaver such as ksolarwinds.kss
2.Move the mouse to return to the desktop
3.
  
Actual results:X seems to hang, and no mouse or keyboard input is possible


Expected results:System should return to the normal KDE desktop


Additional info:Using ssh to login to the system and doing "killall
ksolarwinds.kss" immediately returns the system to normal operation with a
working desktop, mouse and keyboard

Comment 1 Mike Cohler 2007-03-02 08:13:13 UTC
Created attachment 149092 [details]
xorg.conf in current system

Comment 2 Mike Cohler 2007-03-02 08:14:15 UTC
Created attachment 149093 [details]
Xorg.0.log

Current Xorg.0.log

Comment 3 Mike Cohler 2007-03-02 08:17:45 UTC
The xorg.conf file was the same file as created by the system when fc6 was
installed. There are no modifications since then. It is problematic trying to
run without any xorg.conf file as the system defaults to a US keyboard which
means I cannot login to the desktop since I use some characters in passwords
which are in different positions on my UK keyboard. 

Comment 4 Mike Cohler 2007-03-02 08:43:13 UTC
Created attachment 149095 [details]
new xorg.conf created with system-config-display

This file is as automatically created but with the Option "XkbLayout" parameter
changed from us to gb.

Comment 5 Mike Cohler 2007-03-02 08:46:03 UTC
I have just done the following tests:
1) I removed the xorg.conf file and restarted X (using telinit 3 followed by
telinit 5) - no new xorg.conf was created! I tried rebooting and still no new
xorg.conf was created. I was unable to login on the keyboard attached to the
computer so needed to ssh in to proceed.
2) I then re-instated the original xorg.conf and restarted X allowing me to
login to the machine normally again. At this point I then ran
"system-config-display --reconfig" to regenerate a new xorg.conf called
xorg.conf.new which I have attached (I had to amend the keyboard setting with a
manual edit). The new Xorg.0.log will follow.

In the next day or so I will then test the effect on the gl screensaver with
this new xorg.conf

Comment 6 Mike Cohler 2007-03-02 08:48:46 UTC
Created attachment 149096 [details]
Xorg.0.log after restarting X

This is the log file after the changes from comment #5

Comment 7 Mike Cohler 2007-03-02 10:41:56 UTC
Created attachment 149098 [details]
Re-doing the attachment as a text file ! Xorg.0.log after the changes

Changing from a bin file to text - my bad previously

Comment 8 Mike Cohler 2007-03-02 19:34:26 UTC
So far today with the new xorg.conf file above the system has not yet hung X!  
I will continue to test and will report back before the end of the weekend. I
have come out of the screensaver about 6 times successfully and no crashes.

Comment 9 Mike Cohler 2007-03-04 12:55:47 UTC
I have repeatedly tested with the new xorg.conf file and there have been no
recurrences so I am closing this bug.

Comment 10 Mike Cohler 2007-03-04 13:00:26 UTC
Although it is still necessary to run system-config-display to generate an
xorg.conf that works I guess this is not an xorg bug as such which was why I
closed it. If this problem recurs when F7 is clean installed on the same system
I will bz from new but refer back to this report.


Note You need to log in before you can comment on or make changes to this bug.