Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230686 - Default Yelp start on in en_US, but application has translated help in Punjabi
Summary: Default Yelp start on in en_US, but application has translated help in Punjabi
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scrollkeeper
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-02 05:49 UTC by A S Alam
Modified: 2013-07-03 00:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-10 13:50:24 UTC


Attachments (Terms of Use)
Yelp directly opened and with gnome-power-manager (deleted)
2007-03-02 05:49 UTC, A S Alam
no flags Details
Punjabi scrollkeep file (deleted)
2007-04-10 01:53 UTC, A S Alam
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 413751 None None None Never

Description A S Alam 2007-03-02 05:49:06 UTC
Description of problem:
everytime I run yelp shows Documtation of Gnome-power-manger in en_US, (although
it start index in Punjabi).
but if help is opened from gnome-power-manager, then it shows in Punjabi

Version-Release number of selected component (if applicable):
yelp-2.16.2-5.fc7

How reproducible:
Everytime for opening yelp directly (by press F1 in gnome)

Steps to Reproduce:
1. Open yelp directly
2. goto system-tools
3. Open 'gnome-power-manager
  
Actual results:
it is in english

Expected results:
should be in Punjabi

Additional info:
for Punjabi test, run gpm in Punjabi, press Help from right Click menu from there

Comment 1 A S Alam 2007-03-02 05:49:07 UTC
Created attachment 149087 [details]
Yelp directly opened and with gnome-power-manager

Comment 2 Matthias Clasen 2007-04-01 15:48:27 UTC
Confirmed, happens for me too

Comment 3 Matthias Clasen 2007-04-02 04:31:07 UTC
After looking around a bit, I believe this is due to missing pa support in 
scrollkeeper. /usr/share/scrollkeeper/Templates does not have a pa subdirectory.

Comment 4 A S Alam 2007-04-02 06:22:13 UTC
How can we add that?

Comment 5 Matthias Clasen 2007-04-02 06:27:28 UTC
copy Templates/C/scrollkeeper_cl.xml to Templates/pa/scrollkeeper_cl.xml
and translate all the title elements. 

Comment 6 A S Alam 2007-04-02 06:32:58 UTC
I means in Upstream, where translator can commit those?

Comment 7 Matthias Clasen 2007-04-02 14:06:56 UTC
Upstream scrolllkeeper is pretty dead unfortunately, so we will have to carry a
patch in our rpm, most likely. The upstream project is hosted at sourceforge, iirc.

Comment 8 A S Alam 2007-04-10 01:53:07 UTC
Created attachment 152079 [details]
Punjabi scrollkeep file

Attaching file, but results are not good with yelp,
is there something else required other than file

Comment 9 Matthias Clasen 2007-04-10 10:19:46 UTC
I think you need to run scrollkeeper-rebuilddb as root after putting the
template in place. After you ran that rebuilddb command, you should have a 
/var/lib/scrollkeeper/pa directory.

Comment 10 A S Alam 2007-04-10 10:41:23 UTC
Thanks, 
it is working:)


Comment 11 Matthias Clasen 2007-04-10 13:50:24 UTC
I've built 0.3.14-11.fc7 with your translation. 


Note You need to log in before you can comment on or make changes to this bug.