Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230683 - hicolor-icon-theme contains cache file
Summary: hicolor-icon-theme contains cache file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hicolor-icon-theme
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 05:08 UTC by Michel Alexandre Salim
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-02 17:33:25 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2007-03-02 05:08:33 UTC
Description of problem:
hicolor-icon-theme contains /usr/share/icons/hicolor/icon-theme.cache, which
should be generated post-install. I only noticed this because it caused a
conflict with banshee-0.11.5-1.fc7, which also erroneously includes this

Version-Release number of selected component (if applicable):
0.10-2

How reproducible:
Always

Steps to Reproduce:
1. Install banshee and hicolor-icon-theme
  
Actual results:
Once one is installed, the other won't install because of a conflict over the file


Expected results:
Neither should contain cache file

Additional info:

Comment 1 Michel Alexandre Salim 2007-03-02 05:14:05 UTC
Related banshee bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=230684

Comment 2 David Zeuthen 2007-03-02 17:33:25 UTC
Actually, this is by design because 

 a) someone has gotta own the cache file so it goes away
    when hicolor-icon-theme is uninstalled

 b) we only touch the cache file in %install (so we can own the file) 
    and it's regenerated in %post

 c) this is a good way to spot bugs like bug 230684



Note You need to log in before you can comment on or make changes to this bug.