Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230680 - perl-devel should be in git's BuildRequires
Summary: perl-devel should be in git's BuildRequires
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: git
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Wright
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 02:37 UTC by Pavel Roskin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-02 21:46:09 UTC


Attachments (Terms of Use)
Patch (deleted)
2007-03-02 02:37 UTC, Pavel Roskin
no flags Details | Diff

Description Pavel Roskin 2007-03-02 02:37:34 UTC
Description of problem:

git should depend on perl-devel for building

Version-Release number of selected component (if applicable):
git-1.5.0.2-1.fc7
perl-devel-5.8.8-14.fc7

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to the latest perl.
2. Make sure perl-devel is not installed.
3. rpmbuild --rebuild git-1.5.0.2-1.fc7.src.rpm
  
Actual results:
make[2]: *** No rule to make target
`/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/config.h', needed by
`perl.mak'.  Stop.

Expected results:
git packages are built

Additional info:
Installing perl-devel fixes the problem.
Please add perl-devel to git's BuildRequires.

Comment 1 Pavel Roskin 2007-03-02 02:37:34 UTC
Created attachment 149083 [details]
Patch

Comment 2 Chris Wright 2007-03-02 20:53:38 UTC
Thanks for the report.  This is odd, because I don't have perl-devel installed,
and it also builds in plague.  I don't mind adding the patch, just wanted to have
a better understanding of the issue.  

Comment 3 Chris Wright 2007-03-02 21:46:09 UTC
I see, my updates were stale (-12), once I found an uptodate mirror, I see
the new perl-devel package.  Fixed, will push out shortly. 


Note You need to log in before you can comment on or make changes to this bug.