Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230670 - D620: LCD backlight doesn't come back when you open lid
Summary: D620: LCD backlight doesn't come back when you open lid
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Dell WW Linux Engineering
QA Contact: Bill Nottingham
Whiteboard: bzcl34nup
Depends On:
Blocks: D620_Tracker FC7Target
TreeView+ depends on / blocked
Reported: 2007-03-02 00:58 UTC by Warren Togami
Modified: 2014-03-17 03:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-04-03 20:41:06 UTC

Attachments (Terms of Use)

Description Warren Togami 2007-03-02 00:58:17 UTC
Closing the lid and opening it again fails to turn the backlight on.  This fails
equally with a kernel VT console and X.

Matt Domsch mentioned that there is a hack you can add to make it work using
programmed ACPI events.  While this solution could be used, it is an incomplete

- How does our default distro know when to use it?
- Will this work everywhere?  The following cases wont.
    During Anaconda
    During Bootup where it wont have access to the ACPI event scripts
    Kernel panic, showing dump on the screen

Perhaps the only complete solution is to fix the BIOS?

NOTE: Close this bug only if LCD backlight behaves as expected, out-of-the-box,
with default configurations of Fedora.

Comment 1 Kevin Fenzi 2007-03-08 00:10:04 UTC
I have a similar (the same?) problem on a D820. 

The workaround was: 

enable in /etc/acpi/events/video.conf: 

action=/usr/sbin/vbetool dpms on

In rawhide this was suffficent to get it working here. 
In fc6 this still failed to bring the screen back. In addition there I had 
to add to my /etc/X11/xorg.conf:

Section "ServerFlags"
        Option "NoPM" "true"

So, this surely seems like a ACPI bug in the BIOS on these laptops. 
I agree that the above workarounds are just that, workarounds until the BIOS is

Happy to test new bioses or provide more info. 

Comment 2 Jeremy Katz 2007-04-19 00:07:39 UTC
Is this better in X with the intel driver (which we default to now)?

Comment 3 Kevin Fenzi 2007-04-20 02:17:51 UTC
I just tried with the 20070411-i386-live usb image. 
No change. Closing the lid makes the screen blank, and then never come back. 

I tried to change the acpi video.conf, but acpid doesn't seem to be installed on
the livecd. ;( 

Comment 4 Tim Reilly 2007-05-03 20:12:35 UTC
Somewhere between the new d620 bios and installing f7t4 fresh, I can no longer
reproduce this problem. No config changes were made whatsoever.

Comment 5 Kevin Fenzi 2007-05-03 20:29:21 UTC
On my d820, now upgraded to rawhide, I still see this. 
I can work around it by uncommenting the lines in /etc/acpi/events/video.conf: 
action=/usr/sbin/vbetool dpms on

It then works fine. Might be a change between the d820 and d620 bioses. 

Comment 6 Richard Hughes 2007-06-15 15:06:31 UTC
Kevin, if you want to fix this for resume you might want to checkout and
maybe add a --quirk-dpms-on flag.

Comment 7 Kevin Fenzi 2007-06-15 15:28:28 UTC
In reply to comment #6: 

yeah, suspend/resume already works just fine. It already has the right quirks. ;) 
It's only closing the lid/reopening it (without suspending) that has this behavior.

Comment 8 Warren Togami 2007-08-20 14:44:55 UTC
Retest with latest rawhide with default settings?

Comment 9 Kevin Fenzi 2007-09-18 05:53:03 UTC
Sorry for the delay. Just tested with the f8test2 live usb image... 

It seems to work correctly now out of the box and do the right thing. 
This can be closed RAWHIDE as far as I'm concerned. 

Comment 10 Bug Zapper 2008-04-03 19:19:16 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

Comment 11 Kevin Fenzi 2008-04-03 20:41:06 UTC
Closing per comment #9.

Note You need to log in before you can comment on or make changes to this bug.