Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230663 - LSPP: random problems with the python rpm
Summary: LSPP: random problems with the python rpm
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: s390x
OS: Linux
urgent
medium
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 234654 RHEL5LSPPCertTracker
TreeView+ depends on / blocked
 
Reported: 2007-03-01 23:11 UTC by Kylene J Hall
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 20:47:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
Strace output from recently reported passwd issue (deleted)
2007-03-15 19:25 UTC, Kylene J Hall
no flags Details

Description Kylene J Hall 2007-03-01 23:11:49 UTC
Description of problem:

I am randomly having problems with the python rpm (at least that is what I think
it is related to).  I was just installing 2 identical partitions on the same
machine with the LSPP kickstart.  One installed and came up fine.  The other
when I was trying to update to the latest packages on the dwalsh people page I
got Segmentation Fault every time I attempted yum update.

Something happened to both partititons and I just tried reinstalling again one
is going along fine the other I get
sh-3.1# yum update
/usr/bin/python: symbol lookup error: /usr/lib64/libpython2.4.so.1.0: undefined
symbol:

Sometimes reinstalling the python rpm with rpm -Uvh --replacepkgs helps
sometimes I resort to reinstalling the whole system.

Other weird things I have gotten in the past that seem like they could be
related.  I'll get errors when trying to update packages about gethomedircon
undefined.  Also sometimes passwd returns passwd: Authentication token
manipulation error (which the last time I saw (yesterday) seemed like like a
glibc corruption issue but also happens randomly during install sometimes.

I'll continue to update with any info or patterns I find.


Version-Release number of selected component (if applicable):


How reproducible:
This has been happening randomly on several of the recent builds but I had been
stalling opening this trying to gather data.  It seems totally random.

Steps to Reproduce:
1. Not sure.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2007-03-01 23:54:28 UTC
Are you sure your hardware isn't dying?  Please do a memtest86 run to check

Comment 2 Kylene J Hall 2007-03-02 00:13:31 UTC
Can you tell me how to do this or point me to some instructions (specifically on
a s390x partion)

Comment 3 Kylene J Hall 2007-03-05 22:27:00 UTC
Consensus on the LSPP call earlier today was this is not likely a hardware
problem as I have had it with 2 partitions on one machine and more minorly with
3 partitions on a differnt machine.

Comment 5 Kylene J Hall 2007-03-12 20:12:05 UTC
Ok, now on the "other" machine running a GA VM level is having the issue too. 
First I was getting an Illegal Instruction at line 102 in /etc/init.d/sshd error
when attempting to start sshd on a freshly installed machine.

Now after a second reinstall I get this: /usr/bin/python: symbol lookup error:
/usr/lib64/libpython2.4.so.1.0: undefined symbol:
libsemanage.semanage_install_sandbox: genhomedircon returned error code 127.


Comment 6 Kylene J Hall 2007-03-12 20:36:47 UTC
rpm -Uvh --replacepkg python-2 allowed me to use the setsebool package.

Comment 7 Kylene J Hall 2007-03-14 00:20:25 UTC
Not sure how this is related but when installing today I saw an error when I
updated the kernel during install with yum so I grabbed the package and tried to
update it manually like this.  I also get Illegal Instruction when I attempt to
run zipl.  Attempted to reinstall python (which succeeded) but this problem
persisted.

sh-3.1# rpm -Uvh --replacepkgs kernel-2.6.18-8.1.1.el5.lspp.68.s390x.rpm 
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]
/sbin/new-kernel-pkg: line 90:  4808 Illegal instruction     $lilo >/dev/null

This is what we get when the kernel attempts to boot:
Booting default (2.6.18-8.1.1.el)...
HCPGIR450W CP entered; disabled wait PSW 000A0000 00000102

And when the other kernel is attempted:
CP VI VMSG 2
Booting linux...
HCPGIR450W CP entered; disabled wait PSW 000A0000 00000102


Presumably b/c zipl is corrupted.

On a reinstall everything went fine.


Comment 8 Kylene J Hall 2007-03-15 19:20:26 UTC
Again not sure how this is related but another data point.  After running
several tests this has begun to happen: 

[root/abat_r/SystemLow@KWUSER1 ~]# passwd -S root
Illegal instruction

Reinstalling python had no affect.

The strace output will be attached.


Comment 9 Kylene J Hall 2007-03-15 19:25:25 UTC
Created attachment 150160 [details]
Strace output from recently reported passwd issue

Comment 10 Kylene J Hall 2007-03-19 21:59:06 UTC
As discussed on the LSPP call I was to try this with the lspp.69 kernel however
it happened on install before I was even able to update any to any of the lspp
packages:

Cut and paste from the kickstart install:

*** Common Criteria configuration kickstart ***


Protection profile (capp or lspp) [capp] ? lspp
Bringing up loopback interface:  [  OK  ]
Bringing up interface eth0:  [  OK  ]
error: /usr/share/rhn/RPM-GPG-KEY: import read failed(-1).

Need to install the certification RPM and updated RPM packages:

lspp-eal4-config-ibm-0.21-1.noarch.rpm


[FIXME] Currently you should also upgrade the following packages
[FIXME] from http://people.redhat.com/sgrubb/files/lspp/
[FIXME]
        acl
        audit audit-libs audit-libs-devel audit-libs-python
        kernel kernel-devel
        libacl libacl-devel
        mcstrans
        openssh openssh-clients openssh-server
        pam pam-devel
        selinux-policy selinux-policy-devel selinux-policy-mls
        selinux-policy-strict selinux-policy-targeted
        vixie-cron

FIXME: updates pending
        rbac-self-test (TBD in config RPM)
        cups (New package pending)

[FIXME] Use a ! escape to put them in the current dir before continuing.

Supply a web URL or a local (absolute) directory name.

If you need to mount a device containing the files,
enter '!' and RETURN to get a shell prompt.

Location [ftp://partners.redhat.com/EAL4_RHEL5/IBM/] ? !

Starting interactive shell, type 'exit' when done
sh-3.1# echo "ARP=no" >> /etc/sysconfig/network-scripts/ifcfg-eth0
sh-3.1# vi /etc/yum.repos.d/sgrubb.repo
sh-3.1# yum update
/usr/bin/python: symbol lookup error: /usr/lib64/libpython2.4.so.1.0: undefined
symbol:


Comment 11 Kylene J Hall 2007-03-19 22:11:53 UTC
Again after re-installing the python rpm I was able to complete my yum update.
However, I went on to have the problem where passwd continuously returns: passwd: 

Authentication token manipulation error
Changing password for user root.


Comment 12 Irina Boverman 2007-03-21 18:50:48 UTC
Per 3/20/2007 meeting with IBM, this bug is urgent, since it blocks IBM's
testing effort. 

Comment 13 Kylene J Hall 2007-03-21 19:16:06 UTC
Latest install on the partition with GA vM level and the kernel wouldn't boot in
enforcing the first time because it couldn't load the policy.  So I booted to
permissive and was attempting to re-install the policy rpms:

[root//@KWUSER3 capp-lspp-rpms]# rpm -Uvh --replacepkgs selinux-policy-*
Preparing...                ########################################### [100%]
   1:selinux-policy         ########################################### [ 25%]
   2:selinux-policy-devel   ########################################### [ 50%]
   3:selinux-policy-mls     ########################################### [ 75%]
/usr/bin/python: symbol lookup error: /usr/lib64/libpython2.4.so.1.0: undefined
symbol:
libsemanage.semanage_install_sandbox: genhomedircon returned error code 127.
   4:selinux-policy-targeted########################################### [100%]
/usr/bin/python: symbol lookup error: /usr/lib64/libpython2.4.so.1.0: undefined
symbol:
libsemanage.semanage_install_sandbox: genhomedircon returned error code 127.

After reinstalling the python rpm the above task was able to complete
successfully. And after a relabel I was able to boot enforcing.


Comment 14 George C. Wilson 2007-03-26 20:29:37 UTC
Can this be closed as not a bug?


Note You need to log in before you can comment on or make changes to this bug.