Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230656 - no sound recording
Summary: no sound recording
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 22:44 UTC by Marius Andreiana
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-15 16:18:43 UTC


Attachments (Terms of Use)
lspci -vvv (deleted)
2007-03-01 22:44 UTC, Marius Andreiana
no flags Details
scsconfig.log (deleted)
2007-03-07 07:34 UTC, Marius Andreiana
no flags Details
scsconfig.log (deleted)
2007-03-08 23:51 UTC, Kurt Heine
no flags Details
scsrun.log log file (deleted)
2007-03-08 23:52 UTC, Kurt Heine
no flags Details

Description Marius Andreiana 2007-03-01 22:44:34 UTC
With F7t2 - no sound recording (tested audacity, skype). They lock/skip it
completely. 

alsa-lib-1.0.14-0.2.rc2.fc7
Linux localhost 2.6.20-1.2932.fc7 #1 SMP Thu Feb 15 11:02:47 EST 2007 i686 i686
i386 GNU/Linux

Comment 1 Marius Andreiana 2007-03-01 22:44:34 UTC
Created attachment 149062 [details]
lspci -vvv

Comment 2 Martin Stransky 2007-03-06 17:24:05 UTC
can you please attach /root/scsconfig.log? it can be generated by
system-config-soundcard.

Comment 3 Marius Andreiana 2007-03-07 07:34:50 UTC
Created attachment 149436 [details]
scsconfig.log

Attached

Comment 4 Kurt Heine 2007-03-08 23:49:03 UTC
I am trying to use a sound applcation (xmms/noatun/rhythmbox/etc) and I find
that I am getting no sound.  I have checked all the sound channels and un-muted
them and turned them onto full volume and still no go.  I have even download an
ogg file and tried to run it from the command line using ogg123 and still no go.
 Interesting thing is if I run ogg123 with the '-d oss' it all seems to work
fine.  I get the following output from ogg123 :
===============================================================
[k@localhost Desktop]$ ogg123 -v noa_061222_053.ogg 

Audio Device:   Advanced Linux Sound Architecture (ALSA) output
Author:   Bill Currie <bill@taniwha.org>/Kevin Cody, Jr. <kevinc@wuff.dhs.org>
Comments: Outputs to the Advanced Linux Sound Architecture version 0.9.x.

Playing: noa_061222_053.ogg
Ogg Vorbis stream: 1 channel, 44100 Hz
Vorbis format: Version 0
Bitrate hints: upper=0 nominal=96000 lower=0 window=0
Encoded by: Xiph.Org libVorbis I 20040629
ALSA snd_pcm_hw_params_set_channels error: Invalid argument
Error: Cannot open device alsa09.

Segmentation fault
===============================================================

Running the system-config-soundcard I can get the tune to play without any problems.

I have included my scsconfig.log log file.

- Kurt

Comment 5 Kurt Heine 2007-03-08 23:51:21 UTC
Created attachment 149659 [details]
scsconfig.log

scsconfig.log log file

Comment 6 Kurt Heine 2007-03-08 23:52:07 UTC
Created attachment 149660 [details]
scsrun.log log file

scsrun.log log file

Comment 7 Martin von Weissenberg 2007-04-02 12:31:02 UTC
Hello guys,

I have the same problem as the OP on almost identical hardware (Dell Latitude
D820). Running FC6 with ATRPMs, dries and Livna.

By adding 'options snd-hda-intel model=3stack' to
/etc/modprobe.d/sound.localhost, rebooting and fiddling around with alsamixer, I
was able to record sound with Skype Test Call exactly once. After that, the
microphone is totally mute again.

Sound playback has been working fine from day one. I'm mostly using gstreamer.

kernel-2.6.18-1.2869.fc6
alsa-kmdl-2.6.18-1.2869.fc6-1.0.13-56.fc6.at
alsa-driver-1.0.14-58_rc3.fc6.at
alsa-lib-1.0.13-32.fc6.at
alsa-tools-1.0.12-4.fc6

I'm going to recompile the FC7 SRPMS for alsa and see what happens.

--Martin


Comment 8 Martin Stransky 2007-06-26 15:08:57 UTC
new drivers are at http://people.redhat.com/stransky/alsa/

Comment 9 Marius Andreiana 2007-07-08 11:19:53 UTC
WIth current updates, it works for me.
Martin vW, let's close if it's ok for you too.

Comment 10 Martin Stransky 2007-07-09 08:13:14 UTC
okay. what packages/kernel work for you?

Comment 11 Marius Andreiana 2007-07-09 09:23:34 UTC
# rpm -qa|grep alsa
alsa-utils-1.0.14-0.5.rc2.fc7
alsa-utils-1.0.14-0.7.rc2.fc7
alsa-lib-1.0.14-0.4.rc3.fc7
(weird, there are 2 alsa-utils)

kernel-2.6.19-1.2914.fc7


Comment 12 Martin Stransky 2007-08-15 16:18:43 UTC
okay, closing.


Note You need to log in before you can comment on or make changes to this bug.