Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230633 - Yum does not manage kmods properly
Summary: Yum does not manage kmods properly
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 21:36 UTC by Aurelien Bompard
Modified: 2014-01-21 22:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-28 14:21:52 UTC


Attachments (Terms of Use)

Description Aurelien Bompard 2007-03-01 21:36:38 UTC
Description of problem:
I have a locally built kmod for the ipw3945 wifi chipset.
When I try to install the latest RawHide kernel, here's what I get:
# yum install kernel
Loading "changelog" plugin
Loading "installonlyn" plugin
Loading "skip-broken" plugin
Loading "fedorakmod" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
Checking deps for kernel.i686 0-2.6.20-1.2953.fc7 - u
Checking deps for kernel.i686 0-2.6.20-1.2949.fc7 - None
--> Processing Dependency: kernel-i686 = 2.6.20-1.2949.fc7 for package: kmod-ipw3945
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.20-1.2949.fc7 is needed by package
kmod-ipw3945

2949 is what I'm running now, and what my kmod is built for at the moment.
Same problem with --noplugins

The 2949 is not going to be erased by the installonlyn plugin (I have increased
the limit to 5 kernels and I have 3 installed), so why should that cause a
missing dependency with the the kernel's own kmod ? 

Version-Release number of selected component (if applicable):
# rpm -qa | grep -e yum -e kernel -e kmod
yum-3.1.2-1.fc7
kernel-2.6.20-1.2942.fc7
kernel-devel-2.6.20-1.2949.fc7
yum-skip-broken-1.1.1-1.fc7
kernel-devel-2.6.20-1.2953.fc7
yum-changelog-1.1.1-1.fc7
yum-updatesd-3.1.2-1.fc7
kernel-2.6.20-1.2947.fc7
kernel-headers-2.6.20-1.2953.fc7
yum-metadata-parser-1.0.3-2.fc7
yum-fedorakmod-1.1.1-1.fc7
kernel-devel-2.6.20-1.2947.fc7
kmod-ipw3945-1.2.0-2.2.6.20_1.2949.fc7
kernel-devel-2.6.20-1.2942.fc7
yum-utils-1.1.1-1.fc7
kernel-2.6.20-1.2949.fc7


How reproducible:
Always

Steps to Reproduce:
See above

Comment 1 Tim Lauridsen 2007-06-18 08:45:35 UTC
Aurelien,

Do you still have this issue ?

Comment 2 Tim Lauridsen 2007-09-28 12:19:03 UTC
ping Aurelien !

Comment 3 Aurelien Bompard 2007-09-28 14:21:52 UTC
Sorry, I don't use the ipw3945 driver anymore, I use the included iwl3945, so I
don't have this issue anymore, and I can't reproduce it too.
I guess that closes it...


Note You need to log in before you can comment on or make changes to this bug.