Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230609 - Feature Request: Automake 1.10
Summary: Feature Request: Automake 1.10
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: automake
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 19:01 UTC by Debarshi Ray
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-02 12:42:02 UTC


Attachments (Terms of Use)

Description Debarshi Ray 2007-03-01 19:01:18 UTC
Description of problem:

Any project using Automake 1.9.x distributes build tools that will use
non-thread-safe 'mkdir -p'. Automake 1.10 avoids build failures caused by this
when users use 'make -j2'.


Version-Release number of selected component (if applicable):

Automake 1.9.6.


Additional info:

Automake 1.10 needs Autoconf 2.60 or later. .

Here is a feature request for Autoconf 2.61.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=230601

Comment 1 Karsten Hopp 2007-03-02 12:42:02 UTC
Automake-1.10 broke quite a few builds when it replaced automake-1.9.* in our 
buildsystem.
As you seem to be familiar with the autofoo stuff, you should be able to 
rebuild the FC7(rawhide) package on your FC-6 system and cope with the 
resulting build problems. 
But I won't release a automake-1.10 for either FC-5 (bug #229281) or FC-6 as
not everyone is able to fix the resulting problems.


Note You need to log in before you can comment on or make changes to this bug.